[SOLVED] Failling on Ubuntu 16.10 due to ...many things

Trying to build your own version of Vega Strike and having problems? Unix users, paste your config.log here (stderr output alone is not helpful).

[SOLVED] Failling on Ubuntu 16.10 due to ...many things

Postby Itusa » Thu Mar 02, 2017 8:47 pm

I have fixed the compilation errors. https://github.com/Taose/Vegastrike-taose

Current Problem: #15
Old Problems:
Code: Select all
In file included from /projects/Vegastrike/engine/src/cmd/unit.cpp:56:0:
/projects/Vegastrike/engine/src/cmd/unit_jump.h: In instantiation of ‘bool GameUnit<UnitType>::TransferUnitToSystem(unsigned int, StarSystem*&, bool) [with UnitType = Asteroid]’:
/projects/Vegastrike/engine/src/cmd/unit.cpp:726:16:   required from here
/projects/Vegastrike/engine/src/cmd/unit_jump.h:111:43: error: ‘SetCurPosition’ was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of instantiation [-fpermissive]
                             SetCurPosition( this->LocalPosition()+this->cumulative_transformation_matrix
                                            *( 4*( this->rSize()+tester->rSize() ) ) );
/projects/Vegastrike/engine/src/cmd/unit_jump.h:111:43: note: declarations in dependent base ‘Unit’ are not found by unqualified lookup
/projects/Vegastrike/engine/src/cmd/unit_jump.h:111:43: note: use ‘this->SetCurPosition’ instead

I'm really hoping that Klauss will come back, but in the mean time... loki...if you're still around. I could really use some assistance.

I'm currently working with the freenode#vegastrike group to get the project into a compilable state. Initially I couldn't get the SVN to even think about compiling (conflicting instructions, one set requiring using a shell file, the other using cmake) and the stable wouldn't do anything either...so I grabbed the stable source, uploaded to github and got to work.

Now, I'm at a stage where I appear to be further ahead than the SVN in terms of being able to compile it, but still not far enough.

The SVN release compile error talks about an issue whereby the function name and global names were simply out of date and they needed to be corrected for...

Edit: I solved the issue regarding FFMPEG by eliminating from cmake, as per Loki's suggestion. But don't worry, but "SecCurPosition" was not declared in this scope -_-.
Operating System: (Linux) Ubuntu 16.10 (Yakkety)
Vegastrike-taose: 0.5.1
Posts: 85
Topics: 25
Joined: Wed Jul 30, 2014 5:59 pm

Share On:

Share on Facebook Facebook Share on Twitter Twitter Share on Digg Digg

Return to Compiling Problems [paste config.log]

Who is online

Users browsing this forum: No registered users and 3 guests