Can't compile (wat do)

Trying to build your own version of Vega Strike and having problems? Unix users, paste your config.log here (stderr output alone is not helpful).

Can't compile (wat do)

Postby MusilDap » Mon Oct 26, 2015 5:49 pm

so I decided to try getting into vega strike, but compiling with svn is being hard right now

http://vegastrike.sourceforge.net/wiki/ ... alling_SVN

following the steps here, I have all the needed required packages, but up to the compile step is where I have problems

when I do the pre-compile steps, it tells me to use ./bootstrap-sh, but there's no bootstrap file, and ./configure --enable-release doesn't work either

there on out, any other commands relating to installing/ configuring vegastrike do not work because of missing files I didn't get from the svn repositories or something else im missing/forgetting; it doesn't break the OS and I can still install other stuff like packages, just vega strike svn problems

im using openSUSE tumbleweed, and I want to try doing this through svn before ANYTHING else, and for some reason, there's no config.log

what do i do?
MusilDap
Explorer
Explorer
 
Posts: 12
Topics: 1
Joined: Mon Oct 26, 2015 5:22 pm

Share On:

Share on Facebook Facebook Share on Twitter Twitter Share on Digg Digg

Re: Can't compile (wat do)

Postby CLoneWolf » Tue Oct 27, 2015 5:42 am

Hello,
the current recommended way to compile VS is via CMake, as you can read here:
http://wiki.vega-strike.org/HowTo:Compi ... N_on_Linux

To admins: it seems that people find the old guide more easily than the current one, are there prominent links anywhere still pointing to it?
Eventually, could the old one be edited with a header notice pointing to the new one?
CLoneWolf
ISO Party Member
ISO Party Member
 
Posts: 442
Topics: 9
Joined: Thu May 01, 2008 10:14 am

Re: Can't compile (wat do)

Postby MusilDap » Fri Oct 30, 2015 12:17 am

there seems to be errors each time I compile, and I tested this with the cmake-gui package I downloaded (I couldn't get the cmake-curses-gui package for some reason), using the unix makefiles as my current generator, and errors have been logged

hopefully the 2 log files I attached will help

just to clarify, I might play this game, but now this is more or less a self-assigned test for me to see if I can get this working, and I ain't stopping until I do (or until some other event happens)
Attachments
CMakeError.log
(2.84 KiB) Downloaded 73 times
CMakeOutput.log
(53.31 KiB) Downloaded 64 times
MusilDap
Explorer
Explorer
 
Posts: 12
Topics: 1
Joined: Mon Oct 26, 2015 5:22 pm

Re: Can't compile (wat do)

Postby CLoneWolf » Fri Oct 30, 2015 8:17 am

From CMakeError.log:

CheckSymbolExists.c:(.text+0x16): undefined reference to `pthread_create'
[...]
/usr/lib64/gcc/x86_64-suse-linux/5/../../../../x86_64-suse-linux/bin/ld: cannot find -lpthreads

There are various alternatives to handle threads, on my Debian the configuration chose pthread, not pthreads, so I have -lpthread in the link.txt file for vegastrike/build/CMakeFiles/vegastrike.dir and vegastrike/build/CMakeFiles/vegaserver.dir
You could try forcing the choice, as in the very last paragraph of this thread:
https://stackoverflow.com/questions/295 ... ompilation
CLoneWolf
ISO Party Member
ISO Party Member
 
Posts: 442
Topics: 9
Joined: Thu May 01, 2008 10:14 am

Re: Can't compile (wat do)

Postby MusilDap » Fri Oct 30, 2015 1:16 pm

if by forcing it you mean at the build step I type "ccmake -pthread .." then I did (sans the quotation marks), but it still didnt work, and I entered set(-pthread) in the cmakelists.txt file and it didn't work, here's the log files again (might end up being the same in some parts)
Attachments
CMakeError.log
(2.84 KiB) Downloaded 67 times
CMakeOutput.log
(53.31 KiB) Downloaded 73 times
MusilDap
Explorer
Explorer
 
Posts: 12
Topics: 1
Joined: Mon Oct 26, 2015 5:22 pm

Re: Can't compile (wat do)

Postby CLoneWolf » Sat Oct 31, 2015 6:57 am

The two errors are still the same; what happens if you replace -lpthreads with -lpthread in vegastrike/build/CMakeFiles/vegastrike.dir/link.txt and vegastrike/build/CMakeFiles/vegaserver.dir/link.txt ?
By the way, make sure your glibc-devel package is installed.
CLoneWolf
ISO Party Member
ISO Party Member
 
Posts: 442
Topics: 9
Joined: Thu May 01, 2008 10:14 am

Re: Can't compile (wat do)

Postby MusilDap » Sat Oct 31, 2015 1:31 pm

CLoneWolf wrote:The two errors are still the same; what happens if you replace -lpthreads with -lpthread in vegastrike/build/CMakeFiles/vegastrike.dir/link.txt and vegastrike/build/CMakeFiles/vegaserver.dir/link.txt ?
By the way, make sure your glibc-devel package is installed.


there is no vegastrike/build/CMakeFiles/vegastrike.dir/link.txt and vegastrike/build/CMakeFiles/vegaserver.dir/link.txt, and the errors still persist, seemingly no matter what I do
MusilDap
Explorer
Explorer
 
Posts: 12
Topics: 1
Joined: Mon Oct 26, 2015 5:22 pm

Re: Can't compile (wat do)

Postby CLoneWolf » Sat Oct 31, 2015 3:13 pm

Maybe those files are created right before executable linking, requiring successful compilation of everything... how about replacing all the occurrences in CMakeCache.txt and then attempting make?
CLoneWolf
ISO Party Member
ISO Party Member
 
Posts: 442
Topics: 9
Joined: Thu May 01, 2008 10:14 am

Re: Can't compile (wat do)

Postby MusilDap » Sat Oct 31, 2015 10:15 pm

if by occurrences you mean -lpthreads with -lpthread, apparently, that's already done during configuring, and trying the make command spits out this: No targets specified and no makefile found. Stop.

anything else?
MusilDap
Explorer
Explorer
 
Posts: 12
Topics: 1
Joined: Mon Oct 26, 2015 5:22 pm

Re: Can't compile (wat do)

Postby CLoneWolf » Sun Nov 01, 2015 8:19 am

Yes, that's what I meant; no makefile? It must have been erased by the previous ccmake attempt; the last thing I can think of right now is a fresh start (deleting at least CMakeCache.txt or, more drastically, erasing everything in build, and then run ccmake .. again) which should recreate your original config with -lpthreads and the Makefile that failed because of that. Then, edit CMakeCache.txt replacing -lpthreads with -lpthread.
Failing that, unless some opensuse user with direct experience chimes in, I fear you'll have to dive into all that search engines can find about the pthread/pthreads duality.
CLoneWolf
ISO Party Member
ISO Party Member
 
Posts: 442
Topics: 9
Joined: Thu May 01, 2008 10:14 am

Re: Can't compile (wat do)

Postby MusilDap » Sun Nov 01, 2015 2:00 pm

it'd be nice if I could do something along the lines of using an app to talk to a person expertly well versed in this (you maybe clonewolf) and when I need them to do what im apparently failing to do, take control of my VM comp temporarily to see if what they do has anymore success then what I'm doing

other than that, I revisited the cmakecache.txt file and saw (in advanced mode), some stuff missing, so I filled in the default data dir automatically since it didn't do it itself, and its saying something along the lines of OPENGL_xmesa_INCLUDE_DIR-NOTFOUND, even the same for PYTHON_LIBRARY_DEBUG-NOTFOUND

it seems im still missing something, but for the life of me I don't know what, but if its a package im missing, then it seems I can't get it through opensuse's package manager; can I manually download it from somewhere else?
MusilDap
Explorer
Explorer
 
Posts: 12
Topics: 1
Joined: Mon Oct 26, 2015 5:22 pm

Re: Can't compile (wat do)

Postby MusilDap » Sun Nov 01, 2015 2:43 pm

as a side note, maybe other people could do this with opensuse tumbleweed, and if they manage to get it working, they could post how they did it here (or wherever it would go) and the steps to compiling with cmake on the wiki entry you gave me clonewolf could be edited to match what they did, because apparently the steps provided seem to have come with an older version, or something along the way is pear-shaping
MusilDap
Explorer
Explorer
 
Posts: 12
Topics: 1
Joined: Mon Oct 26, 2015 5:22 pm

Re: Can't compile (wat do)

Postby MusilDap » Sun Nov 01, 2015 10:34 pm

I DID IT; what I did was went to my package manager in opensuse tumbleweed, and searched for vegastrike, set the vegastrike package to install (which set other ones to install), and then I had the vegastrike and vegastrike-data packages set to not install, thereby installing whatever packages were left that were not vegastrike related, and after I did that, I ran cmake again, and the build files were made

UPDATE: apparently, I still failed something, as when I went to try to run the game from the build folder, it still fails; attached zip folder containing logs
Attachments
make error and cmake logs.zip
this has the make error I copied from terminal in a txt file and the cmake log files as well
(6.35 KiB) Downloaded 75 times
MusilDap
Explorer
Explorer
 
Posts: 12
Topics: 1
Joined: Mon Oct 26, 2015 5:22 pm

Re: Can't compile (wat do)

Postby CLoneWolf » Mon Nov 02, 2015 8:11 am

Yeah it'd be nice to get live assistance from experts in cases like this, and I'm not one of them :)
I've always been lucky enough in my compiling adventures not to need this kind of troubleshooting.
The make error you attached seems to indicate a video card related failure, but if make failed, how can you have the executable?
What do you read on the terminal when you try to run it and it fails?
CLoneWolf
ISO Party Member
ISO Party Member
 
Posts: 442
Topics: 9
Joined: Thu May 01, 2008 10:14 am

Re: Can't compile (wat do)

Postby MusilDap » Mon Nov 02, 2015 3:03 pm

crap, knew I forgot something; I forgot to put in my first post that im running opensuse tumbleweed on vmware player (free edition) because I like to mess around with linux distros occasionally

if by run you mean running it from the build folder, then it says bash: ./build/vegastrike: No such file or directory

god forbid, am I going to have to redownload this and try rebuilding it again, or should I just try a different generator
MusilDap
Explorer
Explorer
 
Posts: 12
Topics: 1
Joined: Mon Oct 26, 2015 5:22 pm

Re: Can't compile (wat do)

Postby CLoneWolf » Tue Nov 03, 2015 6:29 am

Well, actually you left a few bread crumb hints along the thread ;) "went to my package manager in opensuse tumbleweed" "take control of my VM comp"

./build/vegastrike: No such file or directory <---- this means no vegastrike executable was built, because of the failure at make stage

Downloading again won't be necessary, just a make clean if it works, and deleting CMakeCache should be enough for a fresh start.
CLoneWolf
ISO Party Member
ISO Party Member
 
Posts: 442
Topics: 9
Joined: Thu May 01, 2008 10:14 am

Re: Can't compile (wat do)

Postby MusilDap » Tue Nov 03, 2015 3:46 pm

the make clean did what it needed to do, and I deleted the cmahecache file and re-ran cmake under sudo, but after running make, it gave me the very same error last time
MusilDap
Explorer
Explorer
 
Posts: 12
Topics: 1
Joined: Mon Oct 26, 2015 5:22 pm

Re: Can't compile (wat do)

Postby CLoneWolf » Wed Nov 04, 2015 6:31 am

Well, of course; it wasn't meant to solve the problem, just to give you a fresh start without downloading everything again.
CLoneWolf
ISO Party Member
ISO Party Member
 
Posts: 442
Topics: 9
Joined: Thu May 01, 2008 10:14 am

Re: Can't compile (wat do)

Postby MusilDap » Wed Nov 04, 2015 1:26 pm

is there anything else I can do, or could I somehow get someone else to comple it, and they send me a copy of their stuff (through some file hosting site applicable to this forum, like dropbox or whatever)
MusilDap
Explorer
Explorer
 
Posts: 12
Topics: 1
Joined: Mon Oct 26, 2015 5:22 pm

Re: Can't compile (wat do)

Postby CLoneWolf » Thu Nov 05, 2015 6:04 am

Unless some other opensuse user chimes in, I guess you'll have to rely on search engines and see if you can find something useful about the pthread/pthreads issue.
Well, you could also ask about it on the opensuse forum, that's probably the best shot.
CLoneWolf
ISO Party Member
ISO Party Member
 
Posts: 442
Topics: 9
Joined: Thu May 01, 2008 10:14 am

Re: Can't compile (wat do)

Postby MusilDap » Mon Nov 09, 2015 4:23 pm

so being the dip I am, I didn't think of googleing the vid.file.cpp.o, so I did, and it ran me into this link here

http://sourceforge.net/p/vegastrike/bugs/676/

it goes on to say a user says to disable ffmpeg while in ccmake because of missing stuff, so I do, and then I try make again, and it goes through, so now, only thing I need to do is to figure out the controls, and I done did it; also, unless no one here has editing controls on the vega strike wiki, could the steps be changed to add in "set ffmpeg to disable when in ccmake" or whatever, because I believe that is needed
MusilDap
Explorer
Explorer
 
Posts: 12
Topics: 1
Joined: Mon Oct 26, 2015 5:22 pm

Re: Can't compile (wat do)

Postby loki1950 » Mon Nov 09, 2015 10:26 pm

unless no one here has editing controls on the vega strike wiki


You can do it yourself logging into the wiki is simple just use your forum username and pw,BTW since there is no content that uses ffmpeg currently compiling without it is no hardship :mrgreen: You might run into an other small issue pertaining to mesher our cmd line utility for getting objects into the game engine the code has to be modified for newer versions of Ogre3D. Editing the various key-mappings is done in the vegastrike.config file which is XML they are the second section of the file and it is described in the wiki.

@CLoneWolf you where doing a good job so I didn't chime in :wink:

Enjoy the Choice :)
my box::HP Envy i5-6400 @2Q70GHzx4 8 Gb ram/1 Tb(Win10 64)/3 Tb Mint 18/GTX745 4Gb acer S243HL K222HQL
Q8200/Asus P5QDLX/8 Gb ram/WD 2Tb 2-500 G HD/GF GT640 2Gb Mint 17.3 64 bit Win 10 32 bit acer and DELL E6400 4GB ram/100 GB HD Mint 17.3 6
User avatar
loki1950
The Shepherd
 
Posts: 5708
Topics: 51
Joined: Fri May 13, 2005 1:37 pm
Location: Ottawa

Re: Can't compile (wat do)

Postby CLoneWolf » Tue Nov 10, 2015 12:25 pm

Well done, MusilDap !!
loki1950 wrote:@CLoneWolf you where doing a good job so I didn't chime in :wink:

A good job? I feel that what I've done is more like keeping people busy with wild guesses that turn into dead ends, until they figure the issue themselves! :lol:
But if you say so, who am I to object :mrgreen:
CLoneWolf
ISO Party Member
ISO Party Member
 
Posts: 442
Topics: 9
Joined: Thu May 01, 2008 10:14 am



Return to Compiling Problems [paste config.log]

Who is online

Users browsing this forum: No registered users and 1 guest

cron