[solved] unable to install : error in building vid_file.o

Trying to build your own version of Vega Strike and having problems? Unix users, paste your config.log here (stderr output alone is not helpful).

[solved] unable to install : error in building vid_file.o

Postby chocard » Sat Apr 27, 2013 10:00 am

Hi,

I'm unable to install VegaStrike on LinuxMint 13 Maya.

I'm using this tutorial : http://wiki.vega-strike.org/HowTo:Check ... u_Linux%29 but I have an error during the building part. With make I have this result :
Code: Select all
[  8%] Built target OPcollide
[ 31%] Built target engine_com
[ 34%] Built target netgeneric
[ 40%] Built target netlowlevel
[ 44%] Built target mesh_tool
[ 50%] Built target boost_python
[ 52%] Built target vssetup
[ 59%] Built target vegaserver
[ 59%] Building CXX object CMakeFiles/vegastrike.dir/src/gfx/vid_file.o
/home/vincent/Jeux/VegaStrike/vegastrike/src/gfx/vid_file.cpp: In member function ‘void VidFileImpl::convertFrame()’:
/home/vincent/Jeux/VegaStrike/vegastrike/src/gfx/vid_file.cpp:73:53: erreur: ‘img_convert’ was not declared in this scope
/home/vincent/Jeux/VegaStrike/vegastrike/src/gfx/vid_file.cpp: In constructor ‘VidFileImpl::VidFileImpl(size_t, bool)’:
/home/vincent/Jeux/VegaStrike/vegastrike/src/gfx/vid_file.cpp:46:15: attention : ‘VidFileImpl::pStream’ will be initialized after [-Wreorder]
/home/vincent/Jeux/VegaStrike/vegastrike/src/gfx/vid_file.cpp:43:15: attention :   ‘AVFrame* VidFileImpl::pFrameRGB’ [-Wreorder]
/home/vincent/Jeux/VegaStrike/vegastrike/src/gfx/vid_file.cpp:166:5: attention :   lorsqu'initialisé ici [-Wreorder]
/home/vincent/Jeux/VegaStrike/vegastrike/src/gfx/vid_file.cpp:160:14: attention : ‘VidFileImpl::frameBuffer’ will be initialized after [-Wreorder]
/home/vincent/Jeux/VegaStrike/vegastrike/src/gfx/vid_file.cpp:50:17: attention :   ‘uint8_t* VidFileImpl::packetBuffer’ [-Wreorder]
/home/vincent/Jeux/VegaStrike/vegastrike/src/gfx/vid_file.cpp:166:5: attention :   lorsqu'initialisé ici [-Wreorder]
/home/vincent/Jeux/VegaStrike/vegastrike/src/gfx/vid_file.cpp:51:17: attention : ‘VidFileImpl::packetBufferSize’ will be initialized after [-Wreorder]
/home/vincent/Jeux/VegaStrike/vegastrike/src/gfx/vid_file.cpp:48:17: attention :   ‘bool VidFileImpl::frameReady’ [-Wreorder]
/home/vincent/Jeux/VegaStrike/vegastrike/src/gfx/vid_file.cpp:166:5: attention :   lorsqu'initialisé ici [-Wreorder]
/home/vincent/Jeux/VegaStrike/vegastrike/src/gfx/vid_file.cpp: In destructor ‘VidFileImpl::~VidFileImpl()’:
/home/vincent/Jeux/VegaStrike/vegastrike/src/gfx/vid_file.cpp:204:13: attention : ‘void av_close_input_file(AVFormatContext*)’ is deprecated (declared at /usr/include/libavformat/avformat.h:1580) [-Wdeprecated-declarations]
/home/vincent/Jeux/VegaStrike/vegastrike/src/gfx/vid_file.cpp:204:45: attention : ‘void av_close_input_file(AVFormatContext*)’ is deprecated (declared at /usr/include/libavformat/avformat.h:1580) [-Wdeprecated-declarations]
/home/vincent/Jeux/VegaStrike/vegastrike/src/gfx/vid_file.cpp: In member function ‘void VidFileImpl::open(const string&)’:
/home/vincent/Jeux/VegaStrike/vegastrike/src/gfx/vid_file.cpp:217:22: attention : ‘int av_find_stream_info(AVFormatContext*)’ is deprecated (declared at /usr/include/libavformat/avformat.h:1412) [-Wdeprecated-declarations]
/home/vincent/Jeux/VegaStrike/vegastrike/src/gfx/vid_file.cpp:217:54: attention : ‘int av_find_stream_info(AVFormatContext*)’ is deprecated (declared at /usr/include/libavformat/avformat.h:1412) [-Wdeprecated-declarations]
/home/vincent/Jeux/VegaStrike/vegastrike/src/gfx/vid_file.cpp:227:41: attention : comparaison entre des expressions entières signée et non signée [-Wsign-compare]
/home/vincent/Jeux/VegaStrike/vegastrike/src/gfx/vid_file.cpp:244:13: attention : ‘int avcodec_open(AVCodecContext*, AVCodec*)’ is deprecated (declared at /usr/include/libavcodec/avcodec.h:4035) [-Wdeprecated-declarations]
/home/vincent/Jeux/VegaStrike/vegastrike/src/gfx/vid_file.cpp:244:45: attention : ‘int avcodec_open(AVCodecContext*, AVCodec*)’ is deprecated (declared at /usr/include/libavcodec/avcodec.h:4035) [-Wdeprecated-declarations]
/home/vincent/Jeux/VegaStrike/vegastrike/src/gfx/vid_file.cpp:258:39: attention : comparaison entre des expressions entières signée et non signée [-Wsign-compare]
/home/vincent/Jeux/VegaStrike/vegastrike/src/gfx/vid_file.cpp:259:40: attention : comparaison entre des expressions entières signée et non signée [-Wsign-compare]
/home/vincent/Jeux/VegaStrike/vegastrike/src/gfx/vid_file.cpp: In member function ‘bool VidFileImpl::seek(float)’:
/home/vincent/Jeux/VegaStrike/vegastrike/src/gfx/vid_file.cpp:301:28: attention : comparaison entre des expressions entières signée et non signée [-Wsign-compare]
/home/vincent/Jeux/VegaStrike/vegastrike/src/gfx/vid_file.cpp:303:30: attention : comparaison entre des expressions entières signée et non signée [-Wsign-compare]
/home/vincent/Jeux/VegaStrike/vegastrike/src/gfx/vid_file.cpp:316:29: attention : comparaison entre des expressions entières signée et non signée [-Wsign-compare]
make[2]: *** [CMakeFiles/vegastrike.dir/src/gfx/vid_file.o] Erreur 1
make[1]: *** [CMakeFiles/vegastrike.dir/all] Erreur 2
make: *** [all] Erreur 2


What I'm doing wrong ?

Vincent

PS : I already posted this in the wrong forum... I hope it's right now.
Last edited by chocard on Sat May 04, 2013 12:49 pm, edited 1 time in total.
chocard
Trader
Trader
 
Posts: 30
Topics: 4
Joined: Mon Oct 23, 2006 2:47 am

Share On:

Share on Facebook Facebook Share on Twitter Twitter Share on Digg Digg

Re: unable to install : error in building vid_file.o

Postby klauss » Sat Apr 27, 2013 12:17 pm

Disable ffmpeg. It's not necessry ATM, and updating VS to work with the newest ffmpeg is on the To-Do already.
Oíd mortales, el grito sagrado...
Call me "Menes, lord of Cats"
Wing Commander Universe
User avatar
klauss
Elite
Elite
 
Posts: 7243
Topics: 55
Joined: Mon Apr 18, 2005 7:40 am
Location: LS87, Buenos Aires, República Argentina

Re: unable to install : error in building vid_file.o

Postby chocard » Sat Apr 27, 2013 1:09 pm

Thanks for your quick answer. I un-install ffmpeg with Synaptic without any succes.

make give excactly the same result : error at 59%, unable to build vid_file.o.
chocard
Trader
Trader
 
Posts: 30
Topics: 4
Joined: Mon Oct 23, 2006 2:47 am

Re: unable to install : error in building vid_file.o

Postby klauss » Sat Apr 27, 2013 1:14 pm

Uninstalling wasn't necessary. Just run ccmake, and disable the option.
Oíd mortales, el grito sagrado...
Call me "Menes, lord of Cats"
Wing Commander Universe
User avatar
klauss
Elite
Elite
 
Posts: 7243
Topics: 55
Joined: Mon Apr 18, 2005 7:40 am
Location: LS87, Buenos Aires, República Argentina

Re: unable to install : error in building vid_file.o

Postby chocard » Sat Apr 27, 2013 1:57 pm

It works... almost.

I installed ffmpeg again (just in case it's used by other softwares), ran ccmake, disabled the option, ran make and it worked !

But, vssetup, vegaserver and vegastrike are in the build folder, not the vegastrike one. More important, I ran vegastrike, it worked without any sound and with a crash of vegastrike after 5 minutes.
chocard
Trader
Trader
 
Posts: 30
Topics: 4
Joined: Mon Oct 23, 2006 2:47 am

Re: unable to install : error in building vid_file.o

Postby klauss » Sat Apr 27, 2013 6:14 pm

Yeah, in the build folder is where they should be.

Can you run in under gdb and post a stacktrace after it crashes?
Oíd mortales, el grito sagrado...
Call me "Menes, lord of Cats"
Wing Commander Universe
User avatar
klauss
Elite
Elite
 
Posts: 7243
Topics: 55
Joined: Mon Apr 18, 2005 7:40 am
Location: LS87, Buenos Aires, República Argentina

Re: unable to install : error in building vid_file.o

Postby chocard » Sun Apr 28, 2013 1:15 pm

Actually I can't : I run under gbd, and a soon as I arrive at a "crash point" (for exemple when the fighter base appear) vegastrike doesn't crash with return to desk but freeze, I can't do anything.

When I go back to gdb and ask for stacktrace the answer is : "No stack." .

Does it help you ? It seems the issue is about graphism. (even if I don't have any sound too).
chocard
Trader
Trader
 
Posts: 30
Topics: 4
Joined: Mon Oct 23, 2006 2:47 am

Re: unable to install : error in building vid_file.o

Postby loki1950 » Sun Apr 28, 2013 2:50 pm

Then try just running it in a terminal then post the results here when it crashes as an txt file attached to your post.

Enjoy the Choice :)
my box::HP Envy i5-6400 @2Q70GHzx4 8 Gb ram/1 Tb(Win10 64)/3 Tb Mint 18/GTX745 4Gb acer S243HL K222HQL
Q8200/Asus P5QDLX/8 Gb ram/WD 2Tb 2-500 G HD/GF GT640 2Gb Mint 17.3 64 bit Win 10 32 bit acer and DELL E6400 4GB ram/100 GB HD Mint 17.3 6
User avatar
loki1950
The Shepherd
 
Posts: 5708
Topics: 51
Joined: Fri May 13, 2005 1:37 pm
Location: Ottawa

Re: unable to install : error in building vid_file.o

Postby klauss » Sun Apr 28, 2013 3:04 pm

Debugging full-screen mode is nigh-impossible. Try windowed mode, things should work better.

However, you might also want to try disabling shaders.
Oíd mortales, el grito sagrado...
Call me "Menes, lord of Cats"
Wing Commander Universe
User avatar
klauss
Elite
Elite
 
Posts: 7243
Topics: 55
Joined: Mon Apr 18, 2005 7:40 am
Location: LS87, Buenos Aires, República Argentina

Re: unable to install : error in building vid_file.o

Postby chocard » Tue Apr 30, 2013 1:31 pm

Hi,

Thanks a lot for your help.

Unfortunatly, I need it again.
I changed the vssetup : 16Bit Color windowed and no shadders support.
In a terminal a go to the build folder, type : "gdb vegastrike" and "run". The result is a windowed black screen. I need to close the terminal to be able to close vegastrike.

Here is the wrintings in the terminal before closing :
Code: Select all
Starting program: /home/vincent/Jeux/VegaStrike/build/vegastrike
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Registering codec ogg.
 In path /home/vincent/Jeux/VegaStrike/build
Vega Strike 
See http://www.gnu.org/copyleft/gpl.html for license details.

GOT SUBDIR ARG =
Found data in /home/vincent/Jeux/VegaStrike/build/../data
Using /home/vincent/Jeux/VegaStrike/data as data directory
Using .vegastrike as the home directory
Found MODDIR = /home/vincent/Jeux/VegaStrike/data/mods
USING HOMEDIR : /home/vincent/.vegastrike As the home directory
CONFIGFILE - Found a config file in home directory, using : /home/vincent/.vegastrike/vegastrike.config
DATADIR - No datadir specified in config file, using ; /home/vincent/Jeux/VegaStrike/data
SIMULATION_ATOM: 0.05


Adding HQ Textures Pack

MISSION_NAME is empty using : main_menu.mission
Attempt to call ReadFull on a bad file units.csv -1 /home/vincent/Jeux/VegaStrike/data/units/units.csv
running import sys
print(sys.path)
sys.path = ["",r"/home/vincent/Jeux/VegaStrike/data/../hqtextures/modules/builtin",r"/home/vincent/Jeux/VegaStrike/data/../hqtextures/modules/quests",r"/home/vincent/Jeux/VegaStrike/data/../hqtextures/modules/missions",r"/home/vincent/Jeux/VegaStrike/data/../hqtextures/modules/ai",r"/home/vincent/Jeux/VegaStrike/data/../hqtextures/modules",r"/home/vincent/Jeux/VegaStrike/data/../hqtextures/bases",r"/home/vincent/Jeux/VegaStrike/data/modules/builtin",r"/home/vincent/Jeux/VegaStrike/data/modules/quests",r"/home/vincent/Jeux/VegaStrike/data/modules/missions",r"/home/vincent/Jeux/VegaStrike/data/modules/ai",r"/home/vincent/Jeux/VegaStrike/data/modules",r"/home/vincent/Jeux/VegaStrike/data/bases"] + sys.path
['/usr/lib/python2.7/', '/usr/lib/python2.7/plat-linux2', '/usr/lib/python2.7/lib-tk', '/usr/lib/python2.7/lib-old', '/usr/lib/python2.7/lib-dynload']
testing VS randomrunning import sys
print(sys.path)
['', '/home/vincent/Jeux/VegaStrike/data/../hqtextures/modules/builtin', '/home/vincent/Jeux/VegaStrike/data/../hqtextures/modules/quests', '/home/vincent/Jeux/VegaStrike/data/../hqtextures/modules/missions', '/home/vincent/Jeux/VegaStrike/data/../hqtextures/modules/ai', '/home/vincent/Jeux/VegaStrike/data/../hqtextures/modules', '/home/vincent/Jeux/VegaStrike/data/../hqtextures/bases', '/home/vincent/Jeux/VegaStrike/data/modules/builtin', '/home/vincent/Jeux/VegaStrike/data/modules/quests', '/home/vincent/Jeux/VegaStrike/data/modules/missions', '/home/vincent/Jeux/VegaStrike/data/modules/ai', '/home/vincent/Jeux/VegaStrike/data/modules', '/home/vincent/Jeux/VegaStrike/data/bases', '/usr/lib/python2.7/', '/usr/lib/python2.7/plat-linux2', '/usr/lib/python2.7/lib-tk', '/usr/lib/python2.7/lib-old', '/usr/lib/python2.7/lib-dynload']
[New Thread 0x7fffe9b5e700 (LWP 2528)]
[Thread 0x7fffe9b5e700 (LWP 2528) exited]
[New Thread 0x7fffe9b5e700 (LWP 2529)]
[New Thread 0x7fffe535c700 (LWP 2530)]
Creating scene manager...
Creating template manager...
  Initializing renderer...
Vertex shader was successfully compiled to run on hardware.
 
Fragment shader was successfully compiled to run on hardware.
 
[New Thread 0x7fffdd631700 (LWP 2532)]
[New Thread 0x7fffdce30700 (LWP 2533)]
Vertex shader(s) linked, fragment shader(s) linked.

Vertex shader was successfully compiled to run on hardware.
 
Fragment shader was successfully compiled to run on hardware.
 
Vertex shader(s) linked, fragment shader(s) linked.

1 joysticks were found.

The names of the joysticks are:
    Thrustmaster T.Flight Stick X
axes: 4 buttons: 12 hats: 1
[New Thread 0x7fffd3fff700 (LWP 2534)]
FactionXML:LoadXML factions.xml
using NV_CUBE_MAP
Min (0.000000, 0.000000, 0.000000) Max(0.000000, 0.000000, 0.000000) MinLumin 1.000000, MaxLumin 1.000000Read In Star Count 0 used: 2000
Min (0.000000, 0.000000, 0.000000) Max(0.000000, 0.000000, 0.000000) MinLumin 1.000000, MaxLumin 1.000000Read In Star Count 0 used: 38
Loading a starsystem
Loading Star System Special/Empty
FOUND MODIFICATION = player FOR PLAYER #0
CREATING A LOCAL SHIP : dumbfire
Hi helper play 0
HereInitializing optimizer
Vertex shader was successfully compiled to run on hardware.
 
Fragment shader was successfully compiled to run on hardware.
 
Vertex shader(s) linked, fragment shader(s) linked.

Compilation of technique fixed successful
Compilation of technique default successful
Compilation of technique default_simple successful
pox 119990000000.000000 -9000000.000000 -109990000000.000000
CreateVideoTexture could not find preintro.ogv
INFO: Missing video stream preintro.ogv
CreateVideoTexture could not find intro.ogv
INFO: Missing video stream intro.ogv
Force feedback support disabled when compiled
Loading completed, now network init
Loading active missions True
  IS NOW AT  Special/Empty

Launching bases for Special/Empty
Adding news
initin


thanks in advance
chocard
Trader
Trader
 
Posts: 30
Topics: 4
Joined: Mon Oct 23, 2006 2:47 am

Re: unable to install : error in building vid_file.o

Postby klauss » Tue Apr 30, 2013 4:36 pm

Something's wrong. It's compiling shaders, if you noticed. Are you certain you disabled shaders? Are you using the latest data from trunk?
Oíd mortales, el grito sagrado...
Call me "Menes, lord of Cats"
Wing Commander Universe
User avatar
klauss
Elite
Elite
 
Posts: 7243
Topics: 55
Joined: Mon Apr 18, 2005 7:40 am
Location: LS87, Buenos Aires, República Argentina

Re: unable to install : error in building vid_file.o

Postby chocard » Wed May 01, 2013 12:38 pm

Yes, I made the "svn update" stuff today, for data and vegastrike.

And here is a copy of part of my vegastrike.confing (wich is in the data folder) :
Code: Select all
#set Geometry GeomVeryHigh
#set Textures Tex1024
#set FactionTextures faction_tex_on
#set Resolution 1680x1050
#set Sound audio_3d_linux_male
#set MusicAndVolume windows_ext_music_on
#set Computer P1000MHz
#set Color win_16
#set Difficulty medium
#set Mouse no_mouse
#set Joystick joy_normal
#set Shaders noshader
#set AcceleratedVisual gl_accelerated_visual_on
#set Text text_bitmap
#set Autodocker autodocker_off
#set Censorship censored


Shader is : noshader.
chocard
Trader
Trader
 
Posts: 30
Topics: 4
Joined: Mon Oct 23, 2006 2:47 am

Re: unable to install : error in building vid_file.o

Postby klauss » Wed May 01, 2013 1:45 pm

Did you edit it by hand? Because those #set directives are just comment, so that vssetup knows which settings are enabled. If you did edit it by hand just changing the set directives, you changed nothing. Use vssetup instead.
Oíd mortales, el grito sagrado...
Call me "Menes, lord of Cats"
Wing Commander Universe
User avatar
klauss
Elite
Elite
 
Posts: 7243
Topics: 55
Joined: Mon Apr 18, 2005 7:40 am
Location: LS87, Buenos Aires, República Argentina

Re: unable to install : error in building vid_file.o

Postby chocard » Wed May 01, 2013 4:13 pm

mmm, it's strange.

There is this line juste above the lines I copied : "These line set the currently used settings. This allows them to show up as selected (currently enclosed in [])"

I made this test : in vssetup change the censorship. The line #set Censorship uncensored in vegastrike in the /home/vincent/.vegastrike folder change also. I'm afraid this part is not only comments.
chocard
Trader
Trader
 
Posts: 30
Topics: 4
Joined: Mon Oct 23, 2006 2:47 am

Re: unable to install : error in building vid_file.o

Postby klauss » Wed May 01, 2013 7:07 pm

chocard wrote:I made this test : in vssetup change the censorship. The line #set Censorship uncensored in vegastrike in the /home/vincent/.vegastrike folder change also. I'm afraid this part is not only comments.


It's not the only thing that changes, and it's certainly not the functional thing that changes. Forcing a change there and just there does nothing. Trust me.
Oíd mortales, el grito sagrado...
Call me "Menes, lord of Cats"
Wing Commander Universe
User avatar
klauss
Elite
Elite
 
Posts: 7243
Topics: 55
Joined: Mon Apr 18, 2005 7:40 am
Location: LS87, Buenos Aires, República Argentina

Re: unable to install : error in building vid_file.o

Postby loki1950 » Wed May 01, 2013 9:23 pm

As klauss has said the #set elements are just there so that vssetup can display the current presets the actual changes are way down in the XML structure try viewing the file with syntax highlighting set to XML in your editor gedit,leaf,kwrite or kate
there is a section in the wiki on editing the config file directly.

Enjoy the Choice :)
my box::HP Envy i5-6400 @2Q70GHzx4 8 Gb ram/1 Tb(Win10 64)/3 Tb Mint 18/GTX745 4Gb acer S243HL K222HQL
Q8200/Asus P5QDLX/8 Gb ram/WD 2Tb 2-500 G HD/GF GT640 2Gb Mint 17.3 64 bit Win 10 32 bit acer and DELL E6400 4GB ram/100 GB HD Mint 17.3 6
User avatar
loki1950
The Shepherd
 
Posts: 5708
Topics: 51
Joined: Fri May 13, 2005 1:37 pm
Location: Ottawa

Re: unable to install : error in building vid_file.o

Postby chocard » Thu May 02, 2013 9:20 am

Ho, I trust you. Klauss & loki are quite well knonwn names on this part of the verse... :-D

My next step will be to delete the .vegastrike folder in the USER folder, delete the vegastrike.confing in the data folder, redo the svn update and redo the make. I'll have a clean game.
chocard
Trader
Trader
 
Posts: 30
Topics: 4
Joined: Mon Oct 23, 2006 2:47 am

Re: unable to install : error in building vid_file.o

Postby loki1950 » Thu May 02, 2013 9:56 am

That should work like a charm.Though you should not have to delete the config in the data folder unless it has been corrupted


Enjoy the Choice :)
my box::HP Envy i5-6400 @2Q70GHzx4 8 Gb ram/1 Tb(Win10 64)/3 Tb Mint 18/GTX745 4Gb acer S243HL K222HQL
Q8200/Asus P5QDLX/8 Gb ram/WD 2Tb 2-500 G HD/GF GT640 2Gb Mint 17.3 64 bit Win 10 32 bit acer and DELL E6400 4GB ram/100 GB HD Mint 17.3 6
User avatar
loki1950
The Shepherd
 
Posts: 5708
Topics: 51
Joined: Fri May 13, 2005 1:37 pm
Location: Ottawa

Re: unable to install : error in building vid_file.o

Postby chocard » Fri May 03, 2013 2:05 pm

Bad news : same problems : no sound and crash (or freeze under gdb)

But good news, I succeded in running vegastrike under gdb and I have a stacktrace :
Code: Select all
(gdb) bt
#0  0x00007fffdefa5990 in ?? () from /usr/lib/fglrx/dri/fglrx_dri.so
#1  0x00007fffdf07cfd4 in ?? () from /usr/lib/fglrx/dri/fglrx_dri.so
#2  0x00007fffdf076a71 in ?? () from /usr/lib/fglrx/dri/fglrx_dri.so
#3  0x00007fffdeab32a8 in ?? () from /usr/lib/fglrx/dri/fglrx_dri.so
#4  0x00007fffdeab5074 in ?? () from /usr/lib/fglrx/dri/fglrx_dri.so
#5  0x00007fffde20219e in ?? () from /usr/lib/fglrx/dri/fglrx_dri.so
#6  0x00007fffde202c96 in ?? () from /usr/lib/fglrx/dri/fglrx_dri.so
#7  0x00007fffde0bb8b9 in ?? () from /usr/lib/fglrx/dri/fglrx_dri.so
#8  0x00007fffde0bc3f1 in ?? () from /usr/lib/fglrx/dri/fglrx_dri.so
#9  0x00007fffde3a1020 in ?? () from /usr/lib/fglrx/dri/fglrx_dri.so
#10 0x00000000006fb417 in GFXTextureAddressMode(ADDRESSMODE, TEXTURE_TARGET) ()
#11 0x00000000004aee85 in AnimatedTexture::MakeActive(int, int) ()
#12 0x00000000004bb7df in Animation::DrawNow(Matrix const&) ()
#13 0x00000000004bcbe8 in Animation::ProcessDrawQueue(std::vector<Animation*, std::allocator<Animation*> >&, float) ()
#14 0x000000000050d4c4 in Mesh::ProcessZFarMeshes(bool) ()
#15 0x00000000004a9edc in GameStarSystem::Draw(bool) ()
#16 0x00000000004acbd8 in GameUniverse::StartDraw() ()
#17 0x0000000000499e92 in main_loop() ()
#18 0x00000000007026c6 in winsys_process_events ()
#19 0x0000000000448c9b in main ()


And the gdb "close" cleanly after the freeze :
Code: Select all
Starting program: /home/vincent/Jeux/VegaStrike/build/vegastrike
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Registering codec ogg.
 In path /home/vincent/Jeux/VegaStrike/build
Vega Strike 
See http://www.gnu.org/copyleft/gpl.html for license details.

GOT SUBDIR ARG =
Found data in /home/vincent/Jeux/VegaStrike/build/../data
Using /home/vincent/Jeux/VegaStrike/data as data directory
Using .vegastrike as the home directory
Found MODDIR = /home/vincent/Jeux/VegaStrike/data/mods
USING HOMEDIR : /home/vincent/.vegastrike As the home directory
CONFIGFILE - Found a config file in home directory, using : /home/vincent/.vegastrike/vegastrike.config
DATADIR - No datadir specified in config file, using ; /home/vincent/Jeux/VegaStrike/data
SIMULATION_ATOM: 0.05
MISSION_NAME is empty using : main_menu.mission
Attempt to call ReadFull on a bad file units.csv -1 /home/vincent/Jeux/VegaStrike/data/units/units.csv
running import sys
print(sys.path)
sys.path = ["",r"/home/vincent/Jeux/VegaStrike/data/modules/builtin",r"/home/vincent/Jeux/VegaStrike/data/modules/quests",r"/home/vincent/Jeux/VegaStrike/data/modules/missions",r"/home/vincent/Jeux/VegaStrike/data/modules/ai",r"/home/vincent/Jeux/VegaStrike/data/modules",r"/home/vincent/Jeux/VegaStrike/data/bases"] + sys.path
['/usr/lib/python2.7/', '/usr/lib/python2.7/plat-linux2', '/usr/lib/python2.7/lib-tk', '/usr/lib/python2.7/lib-old', '/usr/lib/python2.7/lib-dynload']
testing VS randomrunning import sys
print(sys.path)
['', '/home/vincent/Jeux/VegaStrike/data/modules/builtin', '/home/vincent/Jeux/VegaStrike/data/modules/quests', '/home/vincent/Jeux/VegaStrike/data/modules/missions', '/home/vincent/Jeux/VegaStrike/data/modules/ai', '/home/vincent/Jeux/VegaStrike/data/modules', '/home/vincent/Jeux/VegaStrike/data/bases', '/usr/lib/python2.7/', '/usr/lib/python2.7/plat-linux2', '/usr/lib/python2.7/lib-tk', '/usr/lib/python2.7/lib-old', '/usr/lib/python2.7/lib-dynload']
[New Thread 0x7fffe9b5e700 (LWP 2787)]
[Thread 0x7fffe9b5e700 (LWP 2787) exited]
[New Thread 0x7fffe9b5e700 (LWP 2788)]
[New Thread 0x7fffe535c700 (LWP 2789)]
Creating scene manager...
Creating template manager...
  Initializing renderer...
Vertex shader was successfully compiled to run on hardware.
 
Fragment shader was successfully compiled to run on hardware.
 
[New Thread 0x7fffdd631700 (LWP 2790)]
[New Thread 0x7fffdce30700 (LWP 2791)]
Vertex shader(s) linked, fragment shader(s) linked.

Vertex shader was successfully compiled to run on hardware.
 
Fragment shader was successfully compiled to run on hardware.
 
Vertex shader(s) linked, fragment shader(s) linked.

1 joysticks were found.

The names of the joysticks are:
    Thrustmaster T.Flight Stick X
axes: 4 buttons: 12 hats: 1
[New Thread 0x7fffd3fff700 (LWP 2792)]
FactionXML:LoadXML factions.xml
using NV_CUBE_MAP
Min (0.000000, 0.000000, 0.000000) Max(0.000000, 0.000000, 0.000000) MinLumin 1.000000, MaxLumin 1.000000Read In Star Count 0 used: 2000
Min (0.000000, 0.000000, 0.000000) Max(0.000000, 0.000000, 0.000000) MinLumin 1.000000, MaxLumin 1.000000Read In Star Count 0 used: 38
Loading a starsystem
Loading Star System Special/Empty
FOUND MODIFICATION = player FOR PLAYER #0
CREATING A LOCAL SHIP : dumbfire
Hi helper play 0
HereInitializing optimizer
Vertex shader was successfully compiled to run on hardware.
 
Fragment shader was successfully compiled to run on hardware.
 
Vertex shader(s) linked, fragment shader(s) linked.

Compilation of technique fixed successful
Compilation of technique default successful
Compilation of technique default_simple successful
pox 119990000000.000000 -9000000.000000 -109990000000.000000
CreateVideoTexture could not find preintro.ogv
INFO: Missing video stream preintro.ogv
CreateVideoTexture could not find intro.ogv
INFO: Missing video stream intro.ogv
Force feedback support disabled when compiled
Loading completed, now network init
Loading active missions True
  IS NOW AT  Special/Empty

Launching bases for Special/Empty
Adding news
initin
Found ship named : Llama.begin
Faction not found assigning default one: privateer
Error: Cannot Open Unit Llama.begin from save file New_Game.
Creating planet JumpTo17-ar with texture jump.texture and technique  - unitlevel <= 2
Creating planet Cephid_17 A with texture stars/white_star.texture and technique  - unitlevel <= 2
Creating planet Atlantis with texture planets/ocean.texture|planets/ocean_specular.texture|planets/earth/earth_clouds.texture and technique earth - unitlevel > 2
Compilation of technique earth successful
Creating planet Phillies with texture planets/rock.texture and technique  - unitlevel > 2
Creating planet JumpToEnyo with texture jump.texture and technique  - unitlevel > 2
Creating planet JumpToCardell with texture jump.texture and technique  - unitlevel > 2
Creating planet JumpToOldziey with texture jump.texture and technique  - unitlevel > 2
Creating planet JumpToEverett with texture jump.texture and technique  - unitlevel > 2
Creating planet JumpToStirling with texture jump.texture and technique  - unitlevel > 2
Creating planet Cephid_17 B with texture stars/red_star.texture and technique  - unitlevel > 2
Creating planet Wiley with texture planets/molten.texture and technique  - unitlevel > 2
Compilation of technique fireglass successful
Creating planet Broadway with texture sol/ganymede.texture|planets/rock.texture and technique  - unitlevel > 2
using NV_CUBE_MAP
Min (0.000000, 0.000000, 0.000000) Max(0.000000, 0.000000, 0.000000) MinLumin 1.000000, MaxLumin 1.000000Read In Star Count 0 used: 2000
Min (0.000000, 0.000000, 0.000000) Max(0.000000, 0.000000, 0.000000) MinLumin 1.000000, MaxLumin 1.000000Read In Star Count 0 used: 38
Loading a starsystem
Loading Star System Crucible/Cephid_17
 Next To: Crucible/17-ar
 Next To: Crucible/Stirling
 Next To: Crucible/Cardell
 Next To: Crucible/Enyo
 Next To: Crucible/Everett
 Next To: Crucible/Oldziey
Loading active missions True
Special/Empty  IS NOW AT  Crucible/Cephid_17
Special
Showing splash screen!
Launching bases for Crucible/Cephid_17
Unit file engine00 not found
Adding news
finding nonloaded quest
quest_tutorial
finding quest
quest_tutorial
nonpfact
Processing News
Compiling python module bases/launch_music.py
Compiling python module modules/dj.py
Tutorial quest finished
removing quest

Program received signal SIGBUS, Bus error.
0x00007fffdefa5990 in ?? () from /usr/lib/fglrx/dri/fglrx_dri.so


What's the problem doctors ?

Could it be an issue with the graphic card ? (AMD Radeon HD 6670)
chocard
Trader
Trader
 
Posts: 30
Topics: 4
Joined: Mon Oct 23, 2006 2:47 am

Re: unable to install : error in building vid_file.o

Postby klauss » Fri May 03, 2013 2:45 pm

We've seen this bug from time to time, and have had trouble reproducing it on developer systems. It's a driver thing, but it may be tied to some of the OpenGL calls VS makes, perhaps unusual API usage or something like that.

Try bt full, it includes some more info (like argument values). And try to gather a few of them, to check if they're random. AFAIR, they all happened on GFXTextureAddressMode. That may be a pattern.
Oíd mortales, el grito sagrado...
Call me "Menes, lord of Cats"
Wing Commander Universe
User avatar
klauss
Elite
Elite
 
Posts: 7243
Topics: 55
Joined: Mon Apr 18, 2005 7:40 am
Location: LS87, Buenos Aires, República Argentina

Re: unable to install : error in building vid_file.o

Postby chocard » Fri May 03, 2013 2:49 pm

Actually /usr/lib/fglrx/dri/fglrx_dri.so was the key : I change the driver and voilà, it works ! No more crash when I want to visit the fighter baracks. So thanks a lot ! I can play now.

But, yes, I know, I ask for a lot..., I would like sounds. I have no sound at all. Neither music no ship. Any idea ?
chocard
Trader
Trader
 
Posts: 30
Topics: 4
Joined: Mon Oct 23, 2006 2:47 am

Re: unable to install : error in building vid_file.o

Postby klauss » Fri May 03, 2013 3:07 pm

You're probably missing some OpenAL development libraries.
Oíd mortales, el grito sagrado...
Call me "Menes, lord of Cats"
Wing Commander Universe
User avatar
klauss
Elite
Elite
 
Posts: 7243
Topics: 55
Joined: Mon Apr 18, 2005 7:40 am
Location: LS87, Buenos Aires, República Argentina

Re: unable to install : error in building vid_file.o

Postby chocard » Fri May 03, 2013 3:31 pm

do you have an idea wich one ? libopenal-dev, libopenal1 and libopenal-data version 1:1.13-4ubuntu3 are installed.

and I can "read" the sound & music directly from the data folders.
chocard
Trader
Trader
 
Posts: 30
Topics: 4
Joined: Mon Oct 23, 2006 2:47 am

Re: unable to install : error in building vid_file.o

Postby klauss » Fri May 03, 2013 3:42 pm

chocard wrote:do you have an idea wich one ? libopenal-dev, libopenal1 and libopenal-data version 1:1.13-4ubuntu3 are installed.

and I can "read" the sound & music directly from the data folders.


ccmake should tell you when you configure if there's something missing. The other missing possibility is libvorbis.
Oíd mortales, el grito sagrado...
Call me "Menes, lord of Cats"
Wing Commander Universe
User avatar
klauss
Elite
Elite
 
Posts: 7243
Topics: 55
Joined: Mon Apr 18, 2005 7:40 am
Location: LS87, Buenos Aires, República Argentina

Re: unable to install : error in building vid_file.o

Postby chocard » Sat May 04, 2013 12:48 pm

It works : the problem was coming from the output.

So everything is OK, thanks a lot !
chocard
Trader
Trader
 
Posts: 30
Topics: 4
Joined: Mon Oct 23, 2006 2:47 am



Return to Compiling Problems [paste config.log]

Who is online

Users browsing this forum: No registered users and 2 guests