How to use/setup MVS2010Express

Trying to build your own version of Vega Strike and having problems? Unix users, paste your config.log here (stderr output alone is not helpful).

How to use/setup MVS2010Express

Postby loki1950 » Thu Mar 01, 2012 11:23 am

Can anyone give me a walk through on how to set up VS2010Ex to compile from my svn repo.Let's nail this down and doc it on the wiki as the Windows compile instructions are way out of date :o

Enjoy the Choice :)
my box::HP Envy i5-6400 @2Q70GHzx4 8 Gb ram/1 Tb(Win10 64)/3 Tb Mint 18/GTX745 4Gb acer S243HL K222HQL
Q8200/Asus P5QDLX/8 Gb ram/WD 2Tb 2-500 G HD/GF GT640 2Gb Mint 17.3 64 bit Win 10 32 bit acer and DELL E6400 4GB ram/100 GB HD Mint 17.3 6
User avatar
loki1950
The Shepherd
 
Posts: 5708
Topics: 51
Joined: Fri May 13, 2005 1:37 pm
Location: Ottawa

Share On:

Share on Facebook Facebook Share on Twitter Twitter Share on Digg Digg

Re: How to use/setup MVS2010Express

Postby klauss » Thu Mar 01, 2012 1:32 pm

I think the first thing you would have to do is to check out the vega-vc9 solution and check if it works.
Oíd mortales, el grito sagrado...
Call me "Menes, lord of Cats"
Wing Commander Universe
User avatar
klauss
Elite
Elite
 
Posts: 7243
Topics: 55
Joined: Mon Apr 18, 2005 7:40 am
Location: LS87, Buenos Aires, República Argentina

Re: How to use/setup MVS2010Express

Postby loki1950 » Thu Mar 01, 2012 3:40 pm

Been there done that :wink: After conversion to vs10 format by VS2010 it can seen to open the the source code files :? Even from the editor panes of this IDE.

Enjoy the Choice :)
my box::HP Envy i5-6400 @2Q70GHzx4 8 Gb ram/1 Tb(Win10 64)/3 Tb Mint 18/GTX745 4Gb acer S243HL K222HQL
Q8200/Asus P5QDLX/8 Gb ram/WD 2Tb 2-500 G HD/GF GT640 2Gb Mint 17.3 64 bit Win 10 32 bit acer and DELL E6400 4GB ram/100 GB HD Mint 17.3 6
User avatar
loki1950
The Shepherd
 
Posts: 5708
Topics: 51
Joined: Fri May 13, 2005 1:37 pm
Location: Ottawa

Re: How to use/setup MVS2010Express

Postby log0 » Fri Mar 02, 2012 1:48 am

I've tried this a few months ago. The problem is that you have to recompile libraries compiled with previous visual studio versions. Python only supports vs2008 officially and I couldn't get it compiled with vs2010. Here is a page that might help though: http://wiki.python.org/moin/VS2010
log0
 

Re: How to use/setup MVS2010Express

Postby loki1950 » Sat Mar 03, 2012 8:13 pm

It seems that the problem may be that the source code is in SVN and there is no way that the express version can handle source control as the ability to use VS extensions is not present in the free version :twisted: Have come across several that are usable with the full paid version.So the snl file would need be modified to work with an export from the local SVN repo and others paths would also need adjustment. But I don't know how to do that ATM.

Enjoy the Choice :)
my box::HP Envy i5-6400 @2Q70GHzx4 8 Gb ram/1 Tb(Win10 64)/3 Tb Mint 18/GTX745 4Gb acer S243HL K222HQL
Q8200/Asus P5QDLX/8 Gb ram/WD 2Tb 2-500 G HD/GF GT640 2Gb Mint 17.3 64 bit Win 10 32 bit acer and DELL E6400 4GB ram/100 GB HD Mint 17.3 6
User avatar
loki1950
The Shepherd
 
Posts: 5708
Topics: 51
Joined: Fri May 13, 2005 1:37 pm
Location: Ottawa

Re: How to use/setup MVS2010Express

Postby pheonixstorm » Sun Mar 04, 2012 12:02 am

For express should only need the win7 sdk and express. The sln file should compile fine, though as log0 stated you will need to recompile the dlls. I should still have a copy of VC9 Express around somewhere if you would rather run from that.
Because of YOU Arbiter, MY kids? can't get enough gas. OR NIPPLE! How does that mkae you feeeel? ~ Halo
User avatar
pheonixstorm
Elite
Elite
 
Posts: 1567
Topics: 113
Joined: Mon Jan 25, 2010 7:03 pm

Re: How to use/setup MVS2010Express

Postby loki1950 » Sun Mar 04, 2012 11:50 am

Here's what I get when I try to build.

1>------ Build started: Project: vegastrike, Configuration: Debug Win32 ------
1> jutils.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jquant2.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jquant1.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jmemnobs.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jmemmgr.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jidctred.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jidctint.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jidctfst.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jidctflt.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jfdctint.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jfdctfst.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jfdctflt.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jerror.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jdtrans.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jdsample.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jdpostct.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jdphuff.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jdmerge.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jdmaster.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jdmarker.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> Generating Code...
1> Compiling...
1> jdmainct.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jdinput.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jdhuff.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jddctmgr.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jdcolor.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jdcoefct.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jdatasrc.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jdatadst.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jdapistd.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jdapimin.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jctrans.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jcsample.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jcprepct.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jcphuff.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jcparam.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jcomapi.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jcmaster.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jcmarker.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jcmainct.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jcinit.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> Generating Code...
1> Compiling...
1> jchuff.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jcdctmgr.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jccolor.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jccoefct.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jcapistd.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> jcapimin.cpp
1>c:\users\denis belanger\documents\sourcecode\jpeg-6b\jinclude.h(20): fatal error C1083: Cannot open include file: 'jconfig.h': No such file or directory
1> xml_support.cpp
1>c1xx : fatal error C1083: Cannot open source file: '..\..\vegastrike\src\xml_support.cpp': No such file or directory
1> xml_serializer.cpp
1>c1xx : fatal error C1083: Cannot open source file: '..\..\vegastrike\src\xml_serializer.cpp': No such file or directory
1> vsfilesystem.cpp
1>c1xx : fatal error C1083: Cannot open source file: '..\..\vegastrike\src\vsfilesystem.cpp': No such file or directory
1> vs_globals.cpp
1>c1xx : fatal error C1083: Cannot open source file: '..\..\vegastrike\src\vs_globals.cpp


And on an on see what I mean it can not open anything within the SVN repo.

Enjoy the Choice :)
my box::HP Envy i5-6400 @2Q70GHzx4 8 Gb ram/1 Tb(Win10 64)/3 Tb Mint 18/GTX745 4Gb acer S243HL K222HQL
Q8200/Asus P5QDLX/8 Gb ram/WD 2Tb 2-500 G HD/GF GT640 2Gb Mint 17.3 64 bit Win 10 32 bit acer and DELL E6400 4GB ram/100 GB HD Mint 17.3 6
User avatar
loki1950
The Shepherd
 
Posts: 5708
Topics: 51
Joined: Fri May 13, 2005 1:37 pm
Location: Ottawa

Re: How to use/setup MVS2010Express

Postby log0 » Sun Mar 04, 2012 12:13 pm

Debug build never worked afaik, select release.

vs2008 express web:
http://www.microsoft.com/download/en/de ... x?id=14597

vs2008 express iso:
http://www.microsoft.com/download/en/de ... px?id=3092
log0
 

Re: How to use/setup MVS2010Express

Postby loki1950 » Sun Mar 04, 2012 2:03 pm

Would rather not download the old one using a cellular dongle for internet access(my brother's h'd have a cat ;) )

Enjoy the Choice :)

ps the switch to release did the trick building as I type :D
my box::HP Envy i5-6400 @2Q70GHzx4 8 Gb ram/1 Tb(Win10 64)/3 Tb Mint 18/GTX745 4Gb acer S243HL K222HQL
Q8200/Asus P5QDLX/8 Gb ram/WD 2Tb 2-500 G HD/GF GT640 2Gb Mint 17.3 64 bit Win 10 32 bit acer and DELL E6400 4GB ram/100 GB HD Mint 17.3 6
User avatar
loki1950
The Shepherd
 
Posts: 5708
Topics: 51
Joined: Fri May 13, 2005 1:37 pm
Location: Ottawa

Re: How to use/setup MVS2010Express

Postby pheonixstorm » Sun Mar 04, 2012 3:54 pm

Try moving your svn repo from users/documents to another folder more like C:\VSSource\... or somewhere other than where you currently have it. If its not able to open up ANY of the source files there may be another probelm outside your VC enviornment. What can you compile so far, any other dll or app from source?
Because of YOU Arbiter, MY kids? can't get enough gas. OR NIPPLE! How does that mkae you feeeel? ~ Halo
User avatar
pheonixstorm
Elite
Elite
 
Posts: 1567
Topics: 113
Joined: Mon Jan 25, 2010 7:03 pm

Re: How to use/setup MVS2010Express

Postby loki1950 » Sun Mar 04, 2012 4:40 pm

Had no problem building the OGRE sample browser both debug and release and if I remember Python was included in that build.My build was stopped be the lack of an include that is part of MFC have found solution but have not yet applied it :)

Enjoy the Choice :)
my box::HP Envy i5-6400 @2Q70GHzx4 8 Gb ram/1 Tb(Win10 64)/3 Tb Mint 18/GTX745 4Gb acer S243HL K222HQL
Q8200/Asus P5QDLX/8 Gb ram/WD 2Tb 2-500 G HD/GF GT640 2Gb Mint 17.3 64 bit Win 10 32 bit acer and DELL E6400 4GB ram/100 GB HD Mint 17.3 6
User avatar
loki1950
The Shepherd
 
Posts: 5708
Topics: 51
Joined: Fri May 13, 2005 1:37 pm
Location: Ottawa

Re: How to use/setup MVS2010Express

Postby pheonixstorm » Mon Mar 05, 2012 3:45 am

In trunk jpeg-6b should be in vega-vc9 unless you deleted the files from the vs project and reapplied them manually.

Not sure about the others... Attach a copy of your solution and I will try to load n compile here.
Because of YOU Arbiter, MY kids? can't get enough gas. OR NIPPLE! How does that mkae you feeeel? ~ Halo
User avatar
pheonixstorm
Elite
Elite
 
Posts: 1567
Topics: 113
Joined: Mon Jan 25, 2010 7:03 pm

Re: How to use/setup MVS2010Express

Postby loki1950 » Mon Mar 05, 2012 8:29 am

Ok here's the converted solution just change the extension from txt to sln


Enjoy the Choice :)
Attachments
vegastrike.txt
(2.96 KiB) Downloaded 88 times
my box::HP Envy i5-6400 @2Q70GHzx4 8 Gb ram/1 Tb(Win10 64)/3 Tb Mint 18/GTX745 4Gb acer S243HL K222HQL
Q8200/Asus P5QDLX/8 Gb ram/WD 2Tb 2-500 G HD/GF GT640 2Gb Mint 17.3 64 bit Win 10 32 bit acer and DELL E6400 4GB ram/100 GB HD Mint 17.3 6
User avatar
loki1950
The Shepherd
 
Posts: 5708
Topics: 51
Joined: Fri May 13, 2005 1:37 pm
Location: Ottawa

Re: How to use/setup MVS2010Express

Postby pheonixstorm » Mon Mar 05, 2012 10:59 am

Actually I meant to ask for the solution and project files, not just the solution... sorry. You can attach the project files as is w/o need to rename them to txt now. I added the sln and vcxproj extensions to the attachment list as well as 7z for archives :)
Because of YOU Arbiter, MY kids? can't get enough gas. OR NIPPLE! How does that mkae you feeeel? ~ Halo
User avatar
pheonixstorm
Elite
Elite
 
Posts: 1567
Topics: 113
Joined: Mon Jan 25, 2010 7:03 pm

Re: How to use/setup MVS2010Express

Postby loki1950 » Mon Mar 05, 2012 11:15 am

Ok then I bundle them into a 7z archive and post them around 2:00 pm

Edit: ps Which file do you really need as the archive is about 26.5 MB
Enjoy the Choice :)
my box::HP Envy i5-6400 @2Q70GHzx4 8 Gb ram/1 Tb(Win10 64)/3 Tb Mint 18/GTX745 4Gb acer S243HL K222HQL
Q8200/Asus P5QDLX/8 Gb ram/WD 2Tb 2-500 G HD/GF GT640 2Gb Mint 17.3 64 bit Win 10 32 bit acer and DELL E6400 4GB ram/100 GB HD Mint 17.3 6
User avatar
loki1950
The Shepherd
 
Posts: 5708
Topics: 51
Joined: Fri May 13, 2005 1:37 pm
Location: Ottawa

Re: How to use/setup MVS2010Express

Postby shenle » Mon Mar 05, 2012 4:26 pm

Just throwing in my 2 cents by saying that I was never able to build VS with any "express" version of MSVC++ though I've been trying for at least 3 years.

The only free version of MSVC++ that ever worked for me to compile VS was the 2003 command-line only, in conjunction with SDKs (win and DX), but that stopped working a few years ago when this old version of the compiler started choking on the newer VS code.
make me a sandwich
make: *** No rule to make target 'me'. Stop.
shenle
Confed Special Operative
Confed Special Operative
 
Posts: 380
Topics: 30
Joined: Wed Jan 30, 2008 8:25 pm
Location: hiding in a dark corner

Re: How to use/setup MVS2010Express

Postby pheonixstorm » Mon Mar 05, 2012 5:57 pm

log0 was able to build VS using 2008 for the experimental branch when I first added in the planetary flight code.

@loki1950 I just need the project files: vegastrike\vegastrike.vcxproj, vssetup\vssetup.vcxproj, and vsserver\vsserver.vcxproj
Because of YOU Arbiter, MY kids? can't get enough gas. OR NIPPLE! How does that mkae you feeeel? ~ Halo
User avatar
pheonixstorm
Elite
Elite
 
Posts: 1567
Topics: 113
Joined: Mon Jan 25, 2010 7:03 pm

Re: How to use/setup MVS2010Express

Postby pheonixstorm » Mon Mar 05, 2012 6:17 pm

loki1950 wrote:Would rather not download the old one using a cellular dongle for internet access(my brother's h'd have a cat ;) )

Enjoy the Choice :)

ps the switch to release did the trick building as I type :D


Ok so missed that last line.. Problem with having kids.. you miss the important details when you get distracted. So, anyway, now I know I have to work on the debug build at least.

Also, I included a patch for express users in the VC9 folder: VCExpress.diff, not sure if it will work with VC10 or not, but it should be easy enough to change over. Heres a quick view
Code: Select all
Index: Resources.rc
===================================================================
--- Resources.rc   (revision 12973)
+++ Resources.rc   (working copy)
@@ -7,7 +7,8 @@
 //
 // Generated from the TEXTINCLUDE 2 resource.
 //
-#include "afxres.h"
+//#include "afxres.h"
+#include <WinResrc.h>
 
 /////////////////////////////////////////////////////////////////////////////
 #undef APSTUDIO_READONLY_SYMBOLS


VC paid ses afxres.h while VC free uses WinRerc.h
I have no idea why this is the case, I read up on it once while I was using VC8 Express and compiling ManGos (WoW server clone)

That should fix you up. If not.. well, time to break out the ol express version and create an express solution
Because of YOU Arbiter, MY kids? can't get enough gas. OR NIPPLE! How does that mkae you feeeel? ~ Halo
User avatar
pheonixstorm
Elite
Elite
 
Posts: 1567
Topics: 113
Joined: Mon Jan 25, 2010 7:03 pm

Re: How to use/setup MVS2010Express

Postby loki1950 » Mon Mar 05, 2012 6:49 pm

And that is just where the build stopped so it seems that VC10 follows on from VC9 will try with the patch and report back.


Enjoy the Choice :)
my box::HP Envy i5-6400 @2Q70GHzx4 8 Gb ram/1 Tb(Win10 64)/3 Tb Mint 18/GTX745 4Gb acer S243HL K222HQL
Q8200/Asus P5QDLX/8 Gb ram/WD 2Tb 2-500 G HD/GF GT640 2Gb Mint 17.3 64 bit Win 10 32 bit acer and DELL E6400 4GB ram/100 GB HD Mint 17.3 6
User avatar
loki1950
The Shepherd
 
Posts: 5708
Topics: 51
Joined: Fri May 13, 2005 1:37 pm
Location: Ottawa

Re: How to use/setup MVS2010Express

Postby log0 » Tue Mar 06, 2012 1:07 am

shenle wrote:Just throwing in my 2 cents by saying that I was never able to build VS with any "express" version of MSVC++ though I've been trying for at least 3 years.

The only free version of MSVC++ that ever worked for me to compile VS was the 2003 command-line only, in conjunction with SDKs (win and DX), but that stopped working a few years ago when this old version of the compiler started choking on the newer VS code.

Weird, it compiles just fine with 2008 express. Make sure that you are compiling the release configuration and adjust the rc file(i think this is documented). You don't need win sdk afaik.
log0
 

Re: How to use/setup MVS2010Express

Postby pheonixstorm » Tue Mar 06, 2012 2:37 am

I think a small part of the sdk is required. Best to do a minimal instal of the sdk though as Express lacks a lot of features/files.
Because of YOU Arbiter, MY kids? can't get enough gas. OR NIPPLE! How does that mkae you feeeel? ~ Halo
User avatar
pheonixstorm
Elite
Elite
 
Posts: 1567
Topics: 113
Joined: Mon Jan 25, 2010 7:03 pm

Re: How to use/setup MVS2010Express

Postby loki1950 » Tue Mar 06, 2012 1:00 pm

More info it's afxres.h that is the problem it is not in the include path the right path is
Code: Select all
C:\Program Files\Microsoft SDKs\Windows\v7.1\Samples\winui\tsf\tsfcompart\afxres.h


So how does one add this to the include path in VC2010

The build stopped at viewarea.cpp BTW

Enjoy the Choice :)
my box::HP Envy i5-6400 @2Q70GHzx4 8 Gb ram/1 Tb(Win10 64)/3 Tb Mint 18/GTX745 4Gb acer S243HL K222HQL
Q8200/Asus P5QDLX/8 Gb ram/WD 2Tb 2-500 G HD/GF GT640 2Gb Mint 17.3 64 bit Win 10 32 bit acer and DELL E6400 4GB ram/100 GB HD Mint 17.3 6
User avatar
loki1950
The Shepherd
 
Posts: 5708
Topics: 51
Joined: Fri May 13, 2005 1:37 pm
Location: Ottawa

Re: How to use/setup MVS2010Express

Postby pheonixstorm » Tue Mar 06, 2012 2:08 pm

If it doesn't add it in when you install the sdk then google directions on how to add the path manually. It should be the same as for the paid version though. For mine under VC9 Pro it shows $(WindowsSdkDir)\include under project setting. Just go under TOOLS -> OPTIONS -> scroll to Projects & Solutions and look for VC++ Directories. Should only need to enter the SDK path under Include files and Library Files.

As far as afxres.h, is that the only one that comes up when you run a search? I would think there would be one in the sdk's include folder or an include folder for the express include folder.
Because of YOU Arbiter, MY kids? can't get enough gas. OR NIPPLE! How does that mkae you feeeel? ~ Halo
User avatar
pheonixstorm
Elite
Elite
 
Posts: 1567
Topics: 113
Joined: Mon Jan 25, 2010 7:03 pm

Re: How to use/setup MVS2010Express

Postby loki1950 » Tue Mar 06, 2012 2:56 pm

Maybe just copying into the path would simpler ;)ie. in the include folder.

Edit: just did the copy to the include folder from the Samples one and successfully build VS Setup :D working on main app ATM :mrgreen:
Enjoy the Choice :)
my box::HP Envy i5-6400 @2Q70GHzx4 8 Gb ram/1 Tb(Win10 64)/3 Tb Mint 18/GTX745 4Gb acer S243HL K222HQL
Q8200/Asus P5QDLX/8 Gb ram/WD 2Tb 2-500 G HD/GF GT640 2Gb Mint 17.3 64 bit Win 10 32 bit acer and DELL E6400 4GB ram/100 GB HD Mint 17.3 6
User avatar
loki1950
The Shepherd
 
Posts: 5708
Topics: 51
Joined: Fri May 13, 2005 1:37 pm
Location: Ottawa

Re: How to use/setup MVS2010Express

Postby loki1950 » Tue Mar 06, 2012 3:26 pm

It built but threw this at the linking stage
Code: Select all
flyjoystick.obj : error LNK2001: unresolved external symbol "public: virtual __thiscall FlyByKeyboard::~FlyByKeyboard

(void)" (??1FlyByKeyboard@@UAE@XZ)
1>flykeyboard.obj : error LNK2001: unresolved external symbol "public: virtual __thiscall FlyByKeyboard::~FlyByKeyboard

(void)" (??1FlyByKeyboard@@UAE@XZ)
1>flyjoystick.obj : error LNK2001: unresolved external symbol "public: virtual void __thiscall FlyByKeyboard::Destroy

(void)" (?Destroy@FlyByKeyboard@@UAEXXZ)
1>flykeyboard.obj : error LNK2001: unresolved external symbol "public: virtual void __thiscall FlyByKeyboard::Destroy

(void)" (?Destroy@FlyByKeyboard@@UAEXXZ)
1>flykeyboard.obj : error LNK2001: unresolved external symbol "protected: void __thiscall FlyByKeyboard::KeyboardRollRight

(float)" (?KeyboardRollRight@FlyByKeyboard@@IAEXM@Z)
1>flykeyboard.obj : error LNK2001: unresolved external symbol "protected: void __thiscall FlyByKeyboard::KeyboardRight

(float)" (?KeyboardRight@FlyByKeyboard@@IAEXM@Z)
1>flykeyboard.obj : error LNK2001: unresolved external symbol "protected: void __thiscall FlyByKeyboard::KeyboardUp(float)"

(?KeyboardUp@FlyByKeyboard@@IAEXM@Z)
1>flykeyboard.obj : error LNK2001: unresolved external symbol "public: virtual void __thiscall FlyByKeyboard::Execute

(void)" (?Execute@FlyByKeyboard@@UAEXXZ)
1>C:\Users\Public\Documents\sandbox\vega-vc9\Release\vegastrike.exe : fatal error LNK1120: 6 unresolved externals


Same error as viewtopic.php?f=5&t=18031

Enjoy the Choice :)
my box::HP Envy i5-6400 @2Q70GHzx4 8 Gb ram/1 Tb(Win10 64)/3 Tb Mint 18/GTX745 4Gb acer S243HL K222HQL
Q8200/Asus P5QDLX/8 Gb ram/WD 2Tb 2-500 G HD/GF GT640 2Gb Mint 17.3 64 bit Win 10 32 bit acer and DELL E6400 4GB ram/100 GB HD Mint 17.3 6
User avatar
loki1950
The Shepherd
 
Posts: 5708
Topics: 51
Joined: Fri May 13, 2005 1:37 pm
Location: Ottawa


Next

Return to Compiling Problems [paste config.log]

Who is online

Users browsing this forum: No registered users and 1 guest

cron