objconv/basemaker/sprite.h:9: fatal error: glut.h

Trying to build your own version of Vega Strike and having problems? Unix users, paste your config.log here (stderr output alone is not helpful).

Re: objconv/basemaker/sprite.h:9: fatal error: glut.h

Postby shenle » Mon Dec 20, 2010 7:21 pm

I have never actually tried to build vegastrike in cygwin, either with autotools or cmake. I could try it, but just the idea of adding yet another layer of dependencies and slowdowns... unappealing.
make me a sandwich
make: *** No rule to make target 'me'. Stop.
shenle
Confed Special Operative
Confed Special Operative
 
Posts: 381
Topics: 30
Joined: Wed Jan 30, 2008 8:25 pm
Location: hiding in a dark corner

Share On:

Share on Facebook Facebook Share on Twitter Twitter Share on Digg Digg

Re: objconv/basemaker/sprite.h:9: fatal error: glut.h

Postby breese » Wed Dec 22, 2010 6:18 am

klauss wrote:cmake has been running smothly for a while now. For a time, we supported both during the transition period (when cmake didn't work 100% right), but atm I've been working exclusively with cmake with absolutely no problem whatsoever.

So I'd support the removal of all autotools stuff.

While I generally agree with this move, it may be a bit premature just yet.

I had to install the following packages to get cmake to succeed:
  • libxmu-dev
  • libavcodec-dev
  • libavformat-dev
  • libavutil-dev
  • libswscale-dev
Why are they required by our cmake configuration but not by our autotools configuration? As they are not required by autotools, they are not required by our code base.
breese
Bounty Hunter
Bounty Hunter
 
Posts: 152
Topics: 14
Joined: Thu Sep 02, 2010 1:00 pm

Re: objconv/basemaker/sprite.h:9: fatal error: glut.h

Postby shenle » Wed Dec 22, 2010 7:14 am

They're all part of ffmpeg. I think ffmpeg was added as a requirement in the cmakefiles.
make me a sandwich
make: *** No rule to make target 'me'. Stop.
shenle
Confed Special Operative
Confed Special Operative
 
Posts: 381
Topics: 30
Joined: Wed Jan 30, 2008 8:25 pm
Location: hiding in a dark corner

Re: objconv/basemaker/sprite.h:9: fatal error: glut.h

Postby klauss » Wed Dec 22, 2010 7:41 am

Ya, but I remember making ffmpeg optional even in cmake.

Maybe I made a mistake somewhere in those scripts... but it should be optional.
Oíd mortales, el grito sagrado...
Call me "Menes, lord of Cats"
Wing Commander Universe
User avatar
klauss
Elite
Elite
 
Posts: 7243
Topics: 55
Joined: Mon Apr 18, 2005 7:40 am
Location: LS87, Buenos Aires, República Argentina

Re: objconv/basemaker/sprite.h:9: fatal error: glut.h

Postby breese » Wed Dec 22, 2010 8:56 am

klauss wrote:Ya, but I remember making ffmpeg optional even in cmake.

Maybe I made a mistake somewhere in those scripts... but it should be optional.

You call find_package(FFMPEG) without the REQUIRED option, so it looks ok.

The problem is caused by FindFFMPEG.cmake (which is called by find_package(FFMPEG)). I do not know cmake very well, but I suspect that we have found a bug in it.

FindFFMPEG.cmake is looking for four libraries (libavcodec, libavformat, libavutil, and libswscale.) The first three must be found before FFMPEG is considered found. As we do not require FFMPEG, everything should be just fine. However, it seems that the missing FFMPEG libraries somehow causes the whole configuration process to fail.

I tried to remove the REQUIRED keywords from FindFFMPEG.cmake, and it worked just fine. That is unfortunately not the real fix to the problem.
breese
Bounty Hunter
Bounty Hunter
 
Posts: 152
Topics: 14
Joined: Thu Sep 02, 2010 1:00 pm

Re: objconv/basemaker/sprite.h:9: fatal error: glut.h

Postby strook » Sun Apr 10, 2011 9:00 am

You need to execute cmake out of cygwin and then use /usr/include, instead of c:\cygwin\usr/include

For example.

Then execute eclipse from te cygwin command shell, too. It will find all paths and gcc.
plz visit my vegastrike project branch here

plz support VegaOgre by donating to it!

My systems: Mac mini 1, 4gig RAM;
i5 Quad Core 2400, 300mbit WLAN, 1,3Tbyte HD, 60 GB SSD,
nvidia geforce 8400gs 512MB, 6gig RAM with Ubuntu 11.4,
win7 and hackintosh installed
User avatar
strook
ISO Party Member
ISO Party Member
 
Posts: 461
Topics: 20
Joined: Fri Sep 03, 2010 5:10 am


Previous

Return to Compiling Problems [paste config.log]

Who is online

Users browsing this forum: No registered users and 1 guest