Compiling current SVN under VS 2005

Trying to build your own version of Vega Strike and having problems? Unix users, paste your config.log here (stderr output alone is not helpful).

Compiling current SVN under VS 2005

Postby Dolphin » Tue Sep 21, 2010 3:27 pm

I tried to follow these instructions http://vegastrike.sourceforge.net/wiki/ ... _Compiling using VS 2005, and I came close, I think. When I try to build it, I get two errors:

Error 7 error C2664: 'alcOpenDevice' : cannot convert parameter 1 from 'const char [14]' to 'ALCubyte *' c:\users\john\desktop\svn\vegastrike\src\aldrv\al_init.cpp 160
Error 3 error C3861: 'png_set_expand_gray_1_2_4_to_8': identifier not found c:\users\john\desktop\svn\vegastrike\src\gfx\vsimage.cpp 325

Image

Any ideas of what I did wrong?



Thanks!
Dolphin
Trader
Trader
 
Posts: 16
Topics: 4
Joined: Fri Sep 17, 2010 1:58 pm

Share On:

Share on Facebook Facebook Share on Twitter Twitter Share on Digg Digg

Re: Compiling current SVN under VS 2005

Postby klauss » Tue Sep 21, 2010 3:32 pm

You need newer versions of openal and libpng.

Take a look at this thread. Shenle got the same error, got past it, but not all the way there.
Oíd mortales, el grito sagrado...
Call me "Menes, lord of Cats"
Wing Commander Universe
User avatar
klauss
Elite
Elite
 
Posts: 7243
Topics: 55
Joined: Mon Apr 18, 2005 7:40 am
Location: LS87, Buenos Aires, República Argentina

Re: Compiling current SVN under VS 2005

Postby Dolphin » Tue Sep 21, 2010 4:14 pm

klauss wrote:You need newer versions of openal and libpng.

Take a look at this thread. Shenle got the same error, got past it, but not all the way there.



I read from that page on in the thread, but I couldn't figure out how to upgrade openal and libpng. I'm using VS 2005, are these part of that? My VS 2005 is a non express version for some work stuff, but I could also download one of the express versions if that would be better... if so, what's the best choice? It seems from MS's download site that I can choose between VS 2008 express and VS2010 express. The docs have instructions for 2008 express, so I'm guessing that might be best for me. Do you agree?
Dolphin
Trader
Trader
 
Posts: 16
Topics: 4
Joined: Fri Sep 17, 2010 1:58 pm

Re: Compiling current SVN under VS 2005

Postby klauss » Tue Sep 21, 2010 4:22 pm

I've built VS with 2008 express a while ago (ie: in 2008), it had some manifests issues I couldn't work out, but mostly because by that time I had been a few years removed from windows development and didn't know much about manifests and how all that worked.

It's still the case, but the thing is, VS builds rather fine in 2008 express. It does take a very lengthy install procedure though, you need SDKs all over the place, you have to install them completely manually which is a pain, and you could still end up discovering that the vega-vc8 solution still has an oldish OpenAL (not sure whether it's the case).

So, if I were you, I'd try to google an up to date openal and libpng instead. Installing VS express isn't something I'd recommend to anyone with a legal pro version at hand.
Oíd mortales, el grito sagrado...
Call me "Menes, lord of Cats"
Wing Commander Universe
User avatar
klauss
Elite
Elite
 
Posts: 7243
Topics: 55
Joined: Mon Apr 18, 2005 7:40 am
Location: LS87, Buenos Aires, República Argentina


Return to Compiling Problems [paste config.log]

Who is online

Users browsing this forum: No registered users and 1 guest

cron