vssetup Error: Failed to find Version.txt anywhere.

Trying to build your own version of Vega Strike and having problems? Unix users, paste your config.log here (stderr output alone is not helpful).

vssetup Error: Failed to find Version.txt anywhere.

Postby Indubitableness » Mon Jul 20, 2009 3:53 am

I have also posted this in user help

I've just compiled vegastrike from source. I didn't want to. I tried to install the binaries, but the Install Vega Strike.sh
script seems to crash instantly. So I tried it from source thinking I was missing dependencies. I was. Once I got the
depencies cleared up it compiled beautifully. Installed fine. (I have since tried the install script a second time, after a
make uninstall, and the installer still crashes immediately despite clearing up dependency problems.)

I get this error. CONFIGFILE - No config found in data dir : /vegastrike.config CONFIG FILE NOT FOUND !!!

No big deal I think. Just run vssetup it'll fix everything. No sir. I get this error. vssetup Error: Failed to find Version.txt anywhere.

This error google has no help for. It's as though I'm the first person ever to experience this problem in the entire recorded
history of googling. I simply can not find a solution to this. I did updatedb and locate Version.txt. No such file on any of
my filesystems.

What gives? How do I make this game run? I was very excited to play this game and now I'm just friggen frustrated.

I am currently using slackware 12.2. Attached is my config.log

[edit] I have discovered more information. Apparently I should have an entire /usr/share/vegastrike directory. This is apparently where Version.txt should reside. This directory has not been installed. Furthermore, upon reading the installation instructions for the game I find that there should be a vsinstall.sh script intended to be run from the command line (in the binary release). The first time I tried to install I noticed this file was missing and assumed that maybe it was deprecated and no longer included with the package, but I'm beginning to get suspicious something went wrong during download.

No matter, if anyone can help me figure out how to manually install the ~/.vegastrike, /usr/share/vegastrike, and any other required directories after the game is compiled so I can write myself a slackbuild I would appreciate it.
Attachments
config.log
(137.97 KiB) Downloaded 123 times
Indubitableness
Just a tourist with a frag'd nav console
Just a tourist with a frag'd nav console
 
Posts: 3
Topics: 2
Joined: Mon Jul 20, 2009 3:42 am

Share On:

Share on Facebook Facebook Share on Twitter Twitter Share on Digg Digg

Return to Compiling Problems [paste config.log]

Who is online

Users browsing this forum: No registered users and 2 guests

cron