Issues in vid_file.cpp and ffmpeg

Trying to build your own version of Vega Strike and having problems? Unix users, paste your config.log here (stderr output alone is not helpful).

Issues in vid_file.cpp and ffmpeg

Postby dcarr » Fri Nov 10, 2017 2:08 pm

hey guys im usinging
Code: Select all
Linux Antergos-MercadesBendz 4.13.9-1-ARCH #1 SMP PREEMPT Sun Oct 22 09:07:32 CEST 2017 x86_64 GNU/Linux
and have been trying to compile vegastrike on it for going on 4 days now. i have fixed many errors but this one has me stumped.so here is the error output: https://pastebin.com/tjNagBUt and the config.log: https://pastebin.com/EaaypMfp. i am going to try to install it on a fedora vm until i can get this mess sorted out cause it would probly run better on a real machine so some one pls help! thx.
My laptop: Linux Antergos-MercadesBendz 4.13.11-1-ARCH #1 SMP PREEMPT x86_64 GNU/Linux with 11.7 GiB Ram 8.0GiB Swap, Intel Quad-Core i7 Hyper-Threading 1TB HDD.
dcarr
Explorer
Explorer
 
Posts: 14
Topics: 4
Joined: Wed Oct 10, 2012 11:33 am

Share On:

Share on Facebook Facebook Share on Twitter Twitter Share on Digg Digg

Re: Issues in vid_file.cpp and ffmpeg

Postby loki1950 » Fri Nov 10, 2017 3:59 pm

These errors are due to the fact all of our dependant libraries have evolved while our source code has not so since there are no uses for ffmpeg in the game at all try compiling without it :wink: You will most likely run into more library API changes.

Enjoy the Choice :)
my box::HP Envy i5-6400 @2Q70GHzx4 8 Gb ram/1 Tb(Win10 64)/3 Tb Mint 18/GTX745 4Gb acer S243HL K222HQL
Q8200/Asus P5QDLX/8 Gb ram/WD 2Tb 2-500 G HD/GF GT640 2Gb Mint 17.3 64 bit Win 10 32 bit acer and DELL E6400 4GB ram/100 GB HD Mint 17.3 6
User avatar
loki1950
The Shepherd
 
Posts: 5701
Topics: 51
Joined: Fri May 13, 2005 1:37 pm
Location: Ottawa

Re: Issues in vid_file.cpp and ffmpeg

Postby dcarr » Fri Nov 10, 2017 11:42 pm

cool thats good to know. i feel so silly that was the one thing i didnt try. ok so far so good if you are interested once i get this to work i can offer to post my PACKAGEBUILD file and its folder for use by others.

okay now i started compilng with ffmpeg disabled as well as cegui disabled cause i cant get it to install. as you said there are new errors but im not sure if they have anything to do with ffmpeg disabled. they are thus: https://pastebin.com/rexxuNpf any ideas?
My laptop: Linux Antergos-MercadesBendz 4.13.11-1-ARCH #1 SMP PREEMPT x86_64 GNU/Linux with 11.7 GiB Ram 8.0GiB Swap, Intel Quad-Core i7 Hyper-Threading 1TB HDD.
dcarr
Explorer
Explorer
 
Posts: 14
Topics: 4
Joined: Wed Oct 10, 2012 11:33 am

Re: Issues in vid_file.cpp and ffmpeg

Postby loki1950 » Sat Nov 11, 2017 12:54 pm

We dropped support for the normal config/make a long time ago migrated to cmake details are on the wiki.

Enjoy the Choice :)
my box::HP Envy i5-6400 @2Q70GHzx4 8 Gb ram/1 Tb(Win10 64)/3 Tb Mint 18/GTX745 4Gb acer S243HL K222HQL
Q8200/Asus P5QDLX/8 Gb ram/WD 2Tb 2-500 G HD/GF GT640 2Gb Mint 17.3 64 bit Win 10 32 bit acer and DELL E6400 4GB ram/100 GB HD Mint 17.3 6
User avatar
loki1950
The Shepherd
 
Posts: 5701
Topics: 51
Joined: Fri May 13, 2005 1:37 pm
Location: Ottawa

Re: Issues in vid_file.cpp and ffmpeg

Postby dcarr » Sat Nov 11, 2017 1:17 pm

ive never used cmake before but if you think that thats the problem i will give it a try and keep you posted on my progress or lack of. also in the mean time im running it off of fc26 vm and it freezes at the loading screen at the part where it says loading backgrounds/black light.cube or something like that im not sure why tho.
My laptop: Linux Antergos-MercadesBendz 4.13.11-1-ARCH #1 SMP PREEMPT x86_64 GNU/Linux with 11.7 GiB Ram 8.0GiB Swap, Intel Quad-Core i7 Hyper-Threading 1TB HDD.
dcarr
Explorer
Explorer
 
Posts: 14
Topics: 4
Joined: Wed Oct 10, 2012 11:33 am

Re: Issues in vid_file.cpp and ffmpeg

Postby loki1950 » Sat Nov 11, 2017 3:35 pm

Can you find the run time logs they should be in a hidden folder called .vegastrike they should give some incite on what's happenning.

Enjoy the Choice :)
my box::HP Envy i5-6400 @2Q70GHzx4 8 Gb ram/1 Tb(Win10 64)/3 Tb Mint 18/GTX745 4Gb acer S243HL K222HQL
Q8200/Asus P5QDLX/8 Gb ram/WD 2Tb 2-500 G HD/GF GT640 2Gb Mint 17.3 64 bit Win 10 32 bit acer and DELL E6400 4GB ram/100 GB HD Mint 17.3 6
User avatar
loki1950
The Shepherd
 
Posts: 5701
Topics: 51
Joined: Fri May 13, 2005 1:37 pm
Location: Ottawa

Re: Issues in vid_file.cpp and ffmpeg

Postby dcarr » Sat Nov 11, 2017 5:58 pm

good idea man thanks i discovered that its probably not vegastrike's fault instead it looks like vbox crashes while trying to render that part of vegastrike startup. and as for using cmake wow i got so close to like 89% then got to this errors: https://pastebin.com/dAixF1qB it is not covered in the patch notes i was given so any ideas on how to fix them? i will continue to think of some but i dont know if i will manage to comeup with anything besides trying to disable ogre... unless thats the right answ?
My laptop: Linux Antergos-MercadesBendz 4.13.11-1-ARCH #1 SMP PREEMPT x86_64 GNU/Linux with 11.7 GiB Ram 8.0GiB Swap, Intel Quad-Core i7 Hyper-Threading 1TB HDD.
dcarr
Explorer
Explorer
 
Posts: 14
Topics: 4
Joined: Wed Oct 10, 2012 11:33 am

Re: Issues in vid_file.cpp and ffmpeg

Postby loki1950 » Sat Nov 11, 2017 9:15 pm

Ah mesher is our cmd line tool for converting obj meshes into something the game engine can load so also add --no mesher to the build instructions again Ogre evolved while our code did not :oops: Ogre was needed to create .mesh files for awhile when we experimented with using it as our rendering pipeline or you cut that function out at the source code level :wink: BTW most of our code has been transferred to Github though we still need a lead code maven.

Enjoy the Choice :)
my box::HP Envy i5-6400 @2Q70GHzx4 8 Gb ram/1 Tb(Win10 64)/3 Tb Mint 18/GTX745 4Gb acer S243HL K222HQL
Q8200/Asus P5QDLX/8 Gb ram/WD 2Tb 2-500 G HD/GF GT640 2Gb Mint 17.3 64 bit Win 10 32 bit acer and DELL E6400 4GB ram/100 GB HD Mint 17.3 6
User avatar
loki1950
The Shepherd
 
Posts: 5701
Topics: 51
Joined: Fri May 13, 2005 1:37 pm
Location: Ottawa

Re: Issues in vid_file.cpp and ffmpeg

Postby dcarr » Sat Nov 11, 2017 10:00 pm

wow man it compiled FINALY now i just have to install it and run it *crossing fingers
your tops couldnt have done it w/o u. :D im sry tho i cant maintain the code im just a hobbyest with a vendeta. once i am sure i can get this to work i can give you my PKGBUILD file tho if you want. ill let u know on my progress.
My laptop: Linux Antergos-MercadesBendz 4.13.11-1-ARCH #1 SMP PREEMPT x86_64 GNU/Linux with 11.7 GiB Ram 8.0GiB Swap, Intel Quad-Core i7 Hyper-Threading 1TB HDD.
dcarr
Explorer
Explorer
 
Posts: 14
Topics: 4
Joined: Wed Oct 10, 2012 11:33 am

Re: Issues in vid_file.cpp and ffmpeg

Postby dcarr » Sat Nov 11, 2017 11:46 pm

okay as soon as i downloaded the data i could play it :oops: inside of the build folder... now i just have to move it so i can start it normaly. :wink: once that is done i will lable my post solved so bear with me.
My laptop: Linux Antergos-MercadesBendz 4.13.11-1-ARCH #1 SMP PREEMPT x86_64 GNU/Linux with 11.7 GiB Ram 8.0GiB Swap, Intel Quad-Core i7 Hyper-Threading 1TB HDD.
dcarr
Explorer
Explorer
 
Posts: 14
Topics: 4
Joined: Wed Oct 10, 2012 11:33 am

Re: Issues in vid_file.cpp and ffmpeg

Postby loki1950 » Sun Nov 12, 2017 12:45 pm

Glad you got something usable have fun.

Enjoy the Choice :)
my box::HP Envy i5-6400 @2Q70GHzx4 8 Gb ram/1 Tb(Win10 64)/3 Tb Mint 18/GTX745 4Gb acer S243HL K222HQL
Q8200/Asus P5QDLX/8 Gb ram/WD 2Tb 2-500 G HD/GF GT640 2Gb Mint 17.3 64 bit Win 10 32 bit acer and DELL E6400 4GB ram/100 GB HD Mint 17.3 6
User avatar
loki1950
The Shepherd
 
Posts: 5701
Topics: 51
Joined: Fri May 13, 2005 1:37 pm
Location: Ottawa

Re: Issues in vid_file.cpp and ffmpeg

Postby dcarr » Sun Nov 12, 2017 2:06 pm

same but for some reason it didnt make an install option... oh and oswalds voice is quieter then the ambieant noise like i can hardly hear him. any ideas on how to remidy those two issues? cause iv never heard of a successfuly compiled program not having a make install option i tend to get this error:
Code: Select all
 CMake Error: The source directory "/home/dcarr/temp/yaourt-tmp-dcarr/aur-vegastrike-svn/src/vegastrike-build/install" does not exist.
My laptop: Linux Antergos-MercadesBendz 4.13.11-1-ARCH #1 SMP PREEMPT x86_64 GNU/Linux with 11.7 GiB Ram 8.0GiB Swap, Intel Quad-Core i7 Hyper-Threading 1TB HDD.
dcarr
Explorer
Explorer
 
Posts: 14
Topics: 4
Joined: Wed Oct 10, 2012 11:33 am

Re: Issues in vid_file.cpp and ffmpeg

Postby dcarr » Mon Nov 13, 2017 2:20 pm

um i don't know if ur done helping me due to your sudden lack of responding to my posts but from what i could gather the install issue is due to that optiion lacking in the cmakelists file.
My laptop: Linux Antergos-MercadesBendz 4.13.11-1-ARCH #1 SMP PREEMPT x86_64 GNU/Linux with 11.7 GiB Ram 8.0GiB Swap, Intel Quad-Core i7 Hyper-Threading 1TB HDD.
dcarr
Explorer
Explorer
 
Posts: 14
Topics: 4
Joined: Wed Oct 10, 2012 11:33 am

Re: Issues in vid_file.cpp and ffmpeg

Postby loki1950 » Mon Nov 13, 2017 2:28 pm

I usually use the cmake GUI and it creates an install target but I have never actually used it as I run the game in userland which made adding new ships and such to the game easier.

Enjoy the Choice :)
my box::HP Envy i5-6400 @2Q70GHzx4 8 Gb ram/1 Tb(Win10 64)/3 Tb Mint 18/GTX745 4Gb acer S243HL K222HQL
Q8200/Asus P5QDLX/8 Gb ram/WD 2Tb 2-500 G HD/GF GT640 2Gb Mint 17.3 64 bit Win 10 32 bit acer and DELL E6400 4GB ram/100 GB HD Mint 17.3 6
User avatar
loki1950
The Shepherd
 
Posts: 5701
Topics: 51
Joined: Fri May 13, 2005 1:37 pm
Location: Ottawa



Return to Compiling Problems [paste config.log]

Who is online

Users browsing this forum: No registered users and 2 guests

cron