Play-testers wanted! PU svn branch now using cubemaps.

Forum for discussing various mods for the VS-engine based upon Privateer. (Please play nice now, and extinguish all flaming materials.
Sincerely, The Management)

Play-testers wanted! PU svn branch now using cubemaps.

Postby chuck_starchaser » Mon Mar 22, 2010 3:31 pm

New shaders, cubemaps, Tarsus and Mining Base upgraded to it all.
Thanks to shenle for the new Windows binary.

Windows and Linux testing, (almost) any hardware.

http://wcjunction.com/phpBB2/viewtopic. ... 2964#22964
Last edited by chuck_starchaser on Mon Mar 22, 2010 4:07 pm, edited 1 time in total.
User avatar
chuck_starchaser
Elite
Elite
 
Posts: 8014
Topics: 195
Joined: Thu Sep 04, 2003 9:03 pm
Location: Montreal

Share On:

Share on Facebook Facebook Share on Twitter Twitter Share on Digg Digg

Re: Play-testers wanted! PU svn branch using cubemaps.

Postby chuck_starchaser » Mon Mar 22, 2010 3:50 pm

A few shots:

Image

Image

Image

NOTE: I did enough work, --but only enough work--, on the models' unwraps and textures to make them new shader compliant.
They are still garbage textures. Specially the asteroid is wrecked.
But all the other textures too... They are simply NOT "textures", really.
User avatar
chuck_starchaser
Elite
Elite
 
Posts: 8014
Topics: 195
Joined: Thu Sep 04, 2003 9:03 pm
Location: Montreal

Re: Play-testers wanted! PU svn branch now using cubemaps.

Postby Neskiairti » Mon Mar 22, 2010 5:45 pm

asteroid aside, that is looking alot better. When/if I have time, I might check it out.
Neskiairti
Confed Special Operative
Confed Special Operative
 
Posts: 334
Topics: 11
Joined: Wed Jan 10, 2007 9:10 pm

Re: Play-testers wanted! PU svn branch now using cubemaps.

Postby charlieg » Mon Mar 22, 2010 6:06 pm

I suggest posting somewhere with greater exposure, like here:
http://forum.freegamedev.net/viewforum.php?f=22
Free Gamer - free software games compendium and commentary!
FreeGameDev forum - open source game development community
User avatar
charlieg
Elite Mercenary
Elite Mercenary
 
Posts: 1328
Topics: 56
Joined: Thu Mar 27, 2003 4:51 pm
Location: Manchester, UK

Re: Play-testers wanted! PU svn branch now using cubemaps.

Postby chuck_starchaser » Mon Mar 22, 2010 7:18 pm

Ah; thanks, charlieg, but it's too crappy yet to advertise to the world. I just need a little bit of testing and feedback; just half a dozen players would probably suffice. The models and textures are still total garbage. The time is approaching fast, now, though. Many of the new models are done, or almost done, and many even have bakes already done; so once I work my way up the shader ladder to CineMut, everything will probably get textured rather quickly; starting with the Centurion, which is almost done... 99% kind of thing.
User avatar
chuck_starchaser
Elite
Elite
 
Posts: 8014
Topics: 195
Joined: Thu Sep 04, 2003 9:03 pm
Location: Montreal

Re: Play-testers wanted! PU svn branch now using cubemaps.

Postby klauss » Mon Mar 22, 2010 8:36 pm

Oh... I almost forgot.

Asteroids: roid.tar.bz2

The diffuse texture of the roid is crap, I think, so you should replace it. (I used it to derive the heightmap so it's too correlated to geometry to look nice).

But since the roid is made of basic mesh + modifiers, you can play with it and get many different shapes ;)
Oíd mortales, el grito sagrado...
Call me "Menes, lord of Cats"
Wing Commander Universe
User avatar
klauss
Elite
Elite
 
Posts: 7243
Topics: 55
Joined: Mon Apr 18, 2005 7:40 am
Location: LS87, Buenos Aires, República Argentina

Re: Play-testers wanted! PU svn branch now using cubemaps.

Postby charlieg » Tue Mar 23, 2010 4:44 am

chuck_starchaser wrote:Ah; thanks, charlieg, but it's too crappy yet to advertise to the world. I just need a little bit of testing and feedback; just half a dozen players would probably suffice.

The hint in the title is FreeGameDev forums. People post WIP stuff there. You can title the thread 'Privateer Universe - playtesters needed'.
Free Gamer - free software games compendium and commentary!
FreeGameDev forum - open source game development community
User avatar
charlieg
Elite Mercenary
Elite Mercenary
 
Posts: 1328
Topics: 56
Joined: Thu Mar 27, 2003 4:51 pm
Location: Manchester, UK

Re: Play-testers wanted! PU svn branch now using cubemaps.

Postby chuck_starchaser » Tue Mar 23, 2010 7:28 am

@charlieg: Gottcha.
@klauss: Downloaded the roids; gotta run to work now; I'll look at it tonight.
There must be a solution for roids, out there. The problem of getting a continuous surface all around is not trivial.
Maybe a special shader implementing a procedural algorithm is in order. Or an off-line procedural that is applied
on the basis of 3D position, giving continuity across seams.
User avatar
chuck_starchaser
Elite
Elite
 
Posts: 8014
Topics: 195
Joined: Thu Sep 04, 2003 9:03 pm
Location: Montreal

Re: Play-testers wanted! PU svn branch now using cubemaps.

Postby chuck_starchaser » Thu Mar 25, 2010 7:36 am

Update/bug report:
This is with r12742 in Windows, r12745 in Ubuntu.
Let me say, first, that as far as graphics and collisions (the most worked on parts of the engine recently) the Windows binary
seems to be working just fine.
Screenshot from Windows


Problems in PU in Ubuntu (r12745):

  • A fixer's picture at the bar (Mr. Stahl) shows as a white rectangle; and clicking on him doesn't change the view to sitting at the table, as it should, but rather talks to him at a distance. I haven't tried with other fixers yet; I will, shortly.
  • Damage sparks (particles) appear to have no alpha. They look like white rectangles with fuzzy blue centers. They saturate the screen, due to their large numbers, making the game unplayable.
  • On the HUD, the shields of the ship you're targeting no longer show.

Problems in PU in Windows(r12742):

  • "Helen looks awful"; I'll try and get a screenshot off gorbalad.
  • Missing HUD for mining base (this is probably my own bug; I accidentally svn-deleted the HUD, then restored it, but maybe forgot to commit it back in).

Problems with PU in Linux AND Windows:

  • Some damage weirdness; it seems as if drives/afterburners were now a top priority for damage, and your ship's max speed easily goes down by a lot; but pressing R for a damage Report, (at least in my case, in Ubuntu), shows no apparent damage. For gorbalad, in Windows, it was even worse: He landed, (I presume fixed damage), and took off again; and then his maximum speed was now zero.
  • Sticky screen reddening when taking damage: Frankly, I don't even remember the screen turning red ever in PU when getting shot at; but I may be misremembering; but what's happening now is that the moment you take some damage, the screen acquires a red tint AND stays red-tinted permanently, --or semi-permanently, sometimes it seems to correct itself, I'm not sure under what circumstances.
  • Sporadic game crashes when killing a unit. Happened once in Windows when gorbalad killed the pirate in Stahl mission 1. I tried to reproduce this crash in Ubuntu, but it didn't happen; however, the game crashed on me to the desktop when I killed a pirate during Stahl mission 2. No useful message on stderr.txt. It would seem to me that there must be an exit(0) somewhere when some code tries to use a unit that no longer exists, or something of the sort.

EDIT:
For my part, I'll start looking into what I think are the easier problems, like the mining base hud image, the white rectangle for stahl...
But I don't feel too confident about being able to fix some of the other bugs.
User avatar
chuck_starchaser
Elite
Elite
 
Posts: 8014
Topics: 195
Joined: Thu Sep 04, 2003 9:03 pm
Location: Montreal

Re: Play-testers wanted! PU svn branch now using cubemaps.

Postby chuck_starchaser » Thu Mar 25, 2010 11:31 pm

Another update/bug report:
Revised, based on new info. Basically, most problems show up in Linux AND Windows.


Problems in PU in Ubuntu (r12745):

  • A fixer's picture at the bar (Mr. Stahl) shows as a white rectangle; and clicking on him doesn't change the view to sitting at the table, as it should, but rather talks to him at a distance. I haven't tried with other fixers yet; I will, shortly.


Problems with PU in Linux AND Windows:

  • Some damage weirdness; it seems as if drives/afterburners were now a top priority for damage, and your ship's max speed easily goes down by a lot; but pressing R for a damage Report, (at least in my case, in Ubuntu), shows no apparent damage. For gorbalad, in Windows, it was even worse: He landed, (I presume fixed damage), and took off again; and then his maximum speed was now zero.
  • Sticky screen reddening when taking damage: Frankly, I don't even remember the screen turning red ever in PU when getting shot at; but I may be misremembering; but what's happening now is that the moment you take some damage, the screen acquires a red tint AND stays red-tinted permanently, --or semi-permanently, sometimes it seems to correct itself, I'm not sure under what circumstances.
  • Sporadic game crashes when killing a unit. Happened once in Windows when gorbalad killed the pirate in Stahl mission 1. I tried to reproduce this crash in Ubuntu, but it didn't happen; however, the game crashed on me to the desktop when I killed a pirate during Stahl mission 2. No useful message on stderr.txt. It would seem to me that there must be an exit(0) somewhere when some code tries to use a unit that no longer exists, or something of the sort.
  • Damage sparks (particles) appear to have no alpha. They look like white rectangles with fuzzy blue centers. They saturate the screen, due to their large numbers, making the game unplayable.
  • On the HUD, the shields of the ship you're targeting no longer show.
  • Laser fire looks pink; not red. I think this is due to lack of alpha, like with the damage sparks.
  • No HUD indication of targetted ship's damage.
  • 90% of the time, docking with planet is fine; but other times you don't get the docking signal, and then you crash on the planet, and you're now docked, but damaged.
User avatar
chuck_starchaser
Elite
Elite
 
Posts: 8014
Topics: 195
Joined: Thu Sep 04, 2003 9:03 pm
Location: Montreal

Re: Play-testers wanted! PU svn branch now using cubemaps.

Postby chuck_starchaser » Fri Mar 26, 2010 6:17 am

Other issues:

Bolts have become huge --larger than the ship firing them, in this screenshot:
http://xover.htu.tuwien.ac.at/~cohen/PU/laser2.JPG

This is probably a shader issue, planets are alternating between okay and too bright. In the pictures below,
near the Tarsus, notice the brightness of agricultural planet Helen:
http://xover.htu.tuwien.ac.at/~cohen/PU/laser1.JPG
http://xover.htu.tuwien.ac.at/~cohen/PU/laser2.JPG
The two shots were taken a minute apart; no change in perspective or illumination. That's reported
from Windows; I haven't noticed it happening in Ubuntu; but I wasn't looking for it, either.
User avatar
chuck_starchaser
Elite
Elite
 
Posts: 8014
Topics: 195
Joined: Thu Sep 04, 2003 9:03 pm
Location: Montreal

Re: Play-testers wanted! PU svn branch now using cubemaps.

Postby pheonixstorm » Sat Mar 27, 2010 3:37 am

chuck_starchaser wrote: 90% of the time, docking with planet is fine; but other times you don't get the docking signal, and then you crash on the planet, and you're now docked, but damaged.

This happened with the other binary you were using. I think its a speed issue or some other detection value getting missed. I know using the dev fighter it almost always happened (fun ship for causing really bad things to happen or crash the binary). I remember hearing the armor damaged noise then having to repair after landing. I think once or twice this was even after the docking sfx came up.

I think I also remember...
Some damage weirdness; it seems as if drives/afterburners were now a top priority for damage, and your ship's max speed easily goes down by a lot; but pressing R for a damage Report, (at least in my case, in Ubuntu), shows no apparent damage. For gorbalad, in Windows, it was even worse: He landed, (I presume fixed damage), and took off again; and then his maximum speed was now zero.
I'm not sure though if this was after using the dev ship or just during a normal game though. Probably after running the dev ship. Dev ship does some nasty things to the game even after you stop using it...
Because of YOU Arbiter, MY kids? can't get enough gas. OR NIPPLE! How does that mkae you feeeel? ~ Halo
User avatar
pheonixstorm
Elite
Elite
 
Posts: 1567
Topics: 113
Joined: Mon Jan 25, 2010 7:03 pm

Re: Play-testers wanted! PU svn branch now using cubemaps.

Postby chuck_starchaser » Sat Mar 27, 2010 5:57 pm

Thanks. Okay, I think I will remove the damned devship for good...
User avatar
chuck_starchaser
Elite
Elite
 
Posts: 8014
Topics: 195
Joined: Thu Sep 04, 2003 9:03 pm
Location: Montreal



Return to Privateer Universe

Who is online

Users browsing this forum: No registered users and 1 guest

cron