[BUG] Vegastrike crashes on startup on XP

Find any bugs in Vega Strike? See if someone has already found it, or report them here!

[BUG] Vegastrike crashes on startup on XP

Postby PaulB » Sat Feb 01, 2014 4:28 am

I just installed Vegastrike VS Setup 0.5.1 r1.exe on my Dell XP laptop.
It crashes on startup.
This is the Basic stderr.txt output:
Code: Select all
GOT SUBDIR ARG =
Found data in C:\GAMES\Vega Strike
Using C:\GAMES\Vega Strike as data directory
USING HOMEDIR : C:\GAMES\Vega Strike/.vegastrike As the home directory
CONFIGFILE - No config found in home : C:\GAMES\Vega Strike/.vegastrike/vegastrike.config
CONFIGFILE - No home config file found, using datadir config file : C:\GAMES\Vega Strike/vegastrike.config
MISSION_NAME is empty using : main_menu.mission
Attempt to call ReadFull on a bad file units.csv -1 C:\GAMES\Vega Strike/units/units.csv
running import sys
print sys.path
sys.path = [r"C:\GAMES\Vega Strike\modules\builtin",r"C:\GAMES\Vega Strike\modules\quests",r"C:\GAMES\Vega Strike\modules\missions",r"C:\GAMES\Vega Strike\modules\ai",r"C:\GAMES\Vega Strike\modules",r"C:\GAMES\Vega Strike\bases"] + sys.path
testing VS randomrunning import sys
print sys.path
  Initializing renderer...
Min (0.000000, 0.000000, 0.000000) Max(0.000000, 0.000000, 0.000000) MinLumin 1.000000, MaxLumin 1.000000Read In Star Count 0 used: 2000
Min (0.000000, 0.000000, 0.000000) Max(0.000000, 0.000000, 0.000000) MinLumin 1.000000, MaxLumin 1.000000Read In Star Count 0 used: 38
Loading a starsystem
Loading Star System Special/Empty
FOUND MODIFICATION = player FOR PLAYER #0

It crashes just maybe 1/4 to 1/2 a minute into the loading process.
This is one of the last things I see long enough to be able to read it and find it in the debug=3 log file:
Loading a VSFileSystem::TextureFile : Blast0050.texture
The I see just a couple more Things (loading or something) then it terminates.

There are no errors logged in Event Viewer logs either in Application nor System.
I almost sure I had installed the game before ( a few weeks ago) and it worked but I uninstalled it.
Well after reading the game docs I decided I'd try it out again and reinstalled it but now it won't run.
I even tried again to uninstall and reinstall - same problem.
One note - everytime I install it (even the very 1st time when it worked - I got a popup someting to the effect to either Repair C++ 2008 redist or uninstall. Every time I have selected Repair.
In Add/Remove Programs I see listed C++ 2005 redist, 2 instances of C++ 2008 versions 9.0.21022.08 & 9.0.30729.17, and C++ 2010 redist 10.0.3019
I checked the file in vegastrike and it's the 9.0.30729.17.
PPG uses the 9.0.21022.08
I can't figure out what's wrong. VegaTrek works. Privateer Gemini Gold works.
I've included the stderr.txt with debug=3.
I see a lot ton of NOT FOUND but no errors or anything that says Failed.
The only thing I did after I installed it and before I ran it was to change some key bindings and joystick code in vegastrike.config.
I hope someone can help.
Paul
Attachments
stderr.txt
(496.29 KiB) Downloaded 81 times
PaulB
Merchant
Merchant
 
Posts: 41
Topics: 9
Joined: Mon Oct 07, 2013 1:19 am

Share On:

Share on Facebook Facebook Share on Twitter Twitter Share on Digg Digg

Re: Vegastrike crashes on startup on XP

Postby warpnoob » Sat Feb 01, 2014 9:47 pm

Run vcredist, the OpenAL-installer and the setup, try again and come back here.
warpnoob
Trader
Trader
 
Posts: 19
Topics: 2
Joined: Thu Jan 30, 2014 10:46 am

Re: Vegastrike crashes on startup on XP

Postby loki1950 » Sat Feb 01, 2014 10:51 pm

Good call warpnoob the exe was built with VS2010 so the run time lib is needed but you seem to have a later version so stick with it but do try the OpenAL installer this line in stdout concerns me a bit as that file defines just about everything in game.
Code: Select all
Attempt to call ReadFull on a bad file units.csv -1 C:\GAMES\Vega Strike/units/units.csv


Enjoy the Choice :)
my box::HP Envy i5-6400 @2Q70GHzx4 8 Gb ram/1 Tb(Win10 64)/3 Tb Mint 18/GTX745 4Gb acer S243HL K222HQL
Q8200/Asus P5QDLX/8 Gb ram/WD 2Tb 2-500 G HD/GF GT640 2Gb Mint 17.3 64 bit Win 10 32 bit acer and DELL E6400 4GB ram/100 GB HD Mint 17.3 6
User avatar
loki1950
The Shepherd
 
Posts: 5723
Topics: 51
Joined: Fri May 13, 2005 1:37 pm
Location: Ottawa

Re: Vegastrike crashes on startup on XP

Postby PaulB » Sat Feb 01, 2014 11:34 pm

warpnoob wrote:Run vcredist, the OpenAL-installer and the setup, try again and come back here.


I did all that before even posting - no difference.
Paul
PaulB
Merchant
Merchant
 
Posts: 41
Topics: 9
Joined: Mon Oct 07, 2013 1:19 am

Re: Vegastrike crashes on startup on XP

Postby PaulB » Sat Feb 01, 2014 11:36 pm

UPDATE:
I've got an update.
I've tried a number of things.
(1) I tried lowering Graphics detail and no or lower shaders and no sound (at different times as well as all together). Still crashed and in some cases with lower detail I got bunches of white lines when the loading was trying to display the text loading messages at the bottom of the screen. Also I DID get some debut errors then which may or may not be relevant"

Code: Select all
Creating planet Atlantis with texture planets/ocean.texture|planets/ocean_specular.texture|planets/earth/earth_clouds.texture and technique earth - unitlevel > 2
(1) : error C0201: unsupported version 130
(6) : warning C7022: unrecognized profile specifier "highp"
(6) : warning C7022: unrecognized profile specifier "precision"
(6) : error C0000: syntax error, unexpected ';', expecting identifier or reserved word "operator" or template identifier or type identifier at token ";"
(6) : error C0501: type name expected at token ";"
(1) : warning C7537: OpenGL does not allow 'uniform' after a type specifier
(3) : error C0000: syntax error, unexpected identifier at token "vec4"
(3) : error C0501: type name expected at token "vec4"
(4) : error C0000: syntax error, unexpected identifier at token "vec4"
(4) : error C0501: type name expected at token "vec4"
(5) : error C0000: syntax error, unexpected identifier at token "vec4"
(5) : error C0501: type name expected at token "vec4"
(6) : error C0000: syntax error, unexpected identifier at token "vec4"
(6) : error C0501: type name expected at token "vec4"
(7) : error C0000: syntax error, unexpected identifier at token "vec4"
(7) :
Fragment Program Error: Failed to compile planet/ground_ps3.0
Compilation of technique earth failed... trying 4_ps2.0/earth
Cause: Error compiling program vp:"planet/ground_vs1.1" fp:"planet/ground_ps3.0"

(2) I tried used the Music Fix exe file with not much better results.
THEN
(3) I decided on a wild card - I set graphics detail to Extreme and left all the other settings at their defaults (except I'm using 800x600 Windowed mode - but that's not relevant). And guess what? That fixed the crash on startup.

I can now load the program normally. I must have set Detail to Extreme when I 1st tried the program a month or so back (and then deleted it) and that's why it worked right off the bat.
I have no clue why it crashes with anything less than Extreme Detail except that this laptop is a Dell Precision M65 w/2G ram 1.8G intell dual core, and nvidia Quadro FX 350m - so it's old - circa 2002 or 3 - but It's been running PPG 1.03 at Extreme detail and I lso recently download Evochron Mercenary (newest Versio) to try it's demo to see if I like it and it runs fine.

So my conclusion is Vegastrike needs some more debugging.
Paul
PaulB
Merchant
Merchant
 
Posts: 41
Topics: 9
Joined: Mon Oct 07, 2013 1:19 am

Re: Vegastrike crashes on startup on XP

Postby PaulB » Sat Feb 01, 2014 11:55 pm

loki1950 wrote:Good call warpnoob the exe was built with VS2010 so the run time lib is needed but you seem to have a later version so stick with it but do try the OpenAL installer this line in stdout concerns me a bit as that file defines just about everything in game.
Code: Select all
Attempt to call ReadFull on a bad file units.csv -1 C:\GAMES\Vega Strike/units/units.csv


Enjoy the Choice :)


On a somewhat side note: I seem to read that there are newer versions or modifications or something on the SVN. But whenever I look at anything there it just confuses me to no end.

The version I got is the link here: http://vegastrike.sourceforge.net/getfiles/
for version Vega Strike 0.5.1.r1 which said it was the latest stable release.

If there's something newer and better there - how does one get it and figure out how to install and use it?
I couldn't really find any instructions or anything that helped - and something I saw were so out of date and related to earlier version that I DID notice that. A good forinstance is most anything like the game manual that all seem to refer to v0.5.0. Or dead links that try to send you to the old forum??? that has nothing on it but a message as to a Provider cause trash.

Thanks,
Paul
PaulB
Merchant
Merchant
 
Posts: 41
Topics: 9
Joined: Mon Oct 07, 2013 1:19 am

Re: Vegastrike crashes on startup on XP

Postby warpnoob » Sat Feb 01, 2014 11:59 pm

Honestly, don't do that. 0.5.1. is not stable at all, you risk crashing whenever you come near a jumppoint. Try 0.5.0. instead, has caused me no problems so far.
warpnoob
Trader
Trader
 
Posts: 19
Topics: 2
Joined: Thu Jan 30, 2014 10:46 am

Re: Vegastrike crashes on startup on XP

Postby PaulB » Sun Feb 02, 2014 12:20 am

warpnoob wrote:Honestly, don't do that. 0.5.1. is not stable at all, you risk crashing whenever you come near a jumppoint. Try 0.5.0. instead, has caused me no problems so far.


Where can I get 0.5.0 ? I haven't seen it anywhere.
Paul
PaulB
Merchant
Merchant
 
Posts: 41
Topics: 9
Joined: Mon Oct 07, 2013 1:19 am

Re: Vegastrike crashes on startup on XP

Postby warpnoob » Sun Feb 02, 2014 12:21 am

warpnoob
Trader
Trader
 
Posts: 19
Topics: 2
Joined: Thu Jan 30, 2014 10:46 am

Re: Vegastrike crashes on startup on XP

Postby PaulB » Sun Feb 02, 2014 12:25 am

Isn't that all for Linux?
Paul
PaulB
Merchant
Merchant
 
Posts: 41
Topics: 9
Joined: Mon Oct 07, 2013 1:19 am

Re: Vegastrike crashes on startup on XP

Postby warpnoob » Sun Feb 02, 2014 12:27 am

The one at the bottom isn't.
warpnoob
Trader
Trader
 
Posts: 19
Topics: 2
Joined: Thu Jan 30, 2014 10:46 am

Re: Vegastrike crashes on startup on XP

Postby PaulB » Sun Feb 02, 2014 12:33 am

Thanks,
Paul
PaulB
Merchant
Merchant
 
Posts: 41
Topics: 9
Joined: Mon Oct 07, 2013 1:19 am



Return to Bug Triage

Who is online

Users browsing this forum: No registered users and 1 guest

cron