Cloaking Devices: Notes and issues

Find any bugs in Vega Strike? See if someone has already found it, or report them here!

Cloaking Devices: Notes and issues

Postby travists » Sun Oct 02, 2011 8:10 pm

I like cloaking devices, so with each new SVN I tweak it so they are available, this last round or two I have discovered some things.

1: "I can't install one when I find one."
This appears to be due to the cloaking device introducing a shield leak value. As shields don't leak, the game sees it as a downgrade thus ineligible for purchase. To resolve just delete the shield leak value in the Units.csv file.

2: "I've camped at a research station and never find one of the 'Experimental' cloaking devices."
I recently discovered that when two items share the same name, only the bottom (last) entry is used. As such because the experimental and Aera devices are just called "cloaking device" only the Aera is avalible. To resolve rename one of these in the master_parts_list.csv file and add the corresponding entry in units.csv file.

3: “I got a cloaking ship but it doesn’t cloak.” --I’ve been wondering about this since moving from 5.0 standalone to svn.
The main thing with not cloaking seems to be from the visual perspective. To fix this I just found that setting the “cloak glass” field in units.csv to 1 turns the ship clear. I have intentionally made ships hostile while I had a cloaking device and can confirm that while cloaked they do not attack. If you have a full color scanner it looks as though this is handled by temporally setting them to neutral.
User avatar
travists
Expert Mercenary
Expert Mercenary
 
Posts: 893
Topics: 33
Joined: Thu Jul 08, 2010 4:43 pm
Location: Sol III North American Continent

Share On:

Share on Facebook Facebook Share on Twitter Twitter Share on Digg Digg

Return to Bug Triage

Who is online

Users browsing this forum: No registered users and 3 guests

cron