My current Bug/Problem..

Find any bugs in Vega Strike? See if someone has already found it, or report them here!

My current Bug/Problem..

Postby SCghst1 » Mon Mar 14, 2011 11:54 pm

stderr
Code: Select all
GOT SUBDIR ARG =
Found data in C:\VS\bin/../data
Using C:\VS\data as data directory
USING HOMEDIR : C:\VS\data/.vegastrike As the home directory
CONFIGFILE - No config found in home : C:\VS\data/.vegastrike/vegastrike.config
CONFIGFILE - No home config file found, using datadir config file : C:\VS\data/vegastrike.config
MISSION_NAME is empty using : main_menu.mission
Attempt to call ReadFull on a bad file units.csv -1 C:\VS\data/units/units.csv
'import site' failed; use -v for traceback
running import sys
print sys.path
sys.path = [r"C:\VS\data\modules\builtin",r"C:\VS\data\modules\quests",r"C:\VS\data\modules\missions",r"C:\VS\data\modules\ai",r"C:\VS\data\modules",r"C:\VS\data\bases"]
testing VS randomrunning import sys
print sys.path
  Initializing renderer...
0(177) : warning C7011: implicit cast from "vec3" to "float"

Fragment info
-------------
0(177) : warning C7011: implicit cast from "vec3" to "float"
0(169) : warning C7050: "mspec_col" might be used before being initialized

Min (0.000000, 0.000000, 0.000000) Max(0.000000, 0.000000, 0.000000) MinLumin 1.000000, MaxLumin 1.000000Read In Star Count 0 used: 2000
Min (0.000000, 0.000000, 0.000000) Max(0.000000, 0.000000, 0.000000) MinLumin 1.000000, MaxLumin 1.000000Read In Star Count 0 used: 38
Loading a starsystem
Loading Star System Special/Empty
FOUND MODIFICATION = player FOR PLAYER #0
0(243) : warning C7011: implicit cast from "vec3" to "float"

Fragment info
-------------
0(243) : warning C7011: implicit cast from "vec3" to "float"

CreateVideoTexture could not find preintro.ogv
CreateVideoTexture could not find intro.ogv
Creating planet JumpTo17-ar with texture jump.texture and technique  - unitlevel <= 2
Creating planet Cephid_17 A with texture stars/white_star.texture and technique  - unitlevel <= 2
Creating planet Atlantis with texture planets/ocean.texture|planets/ocean_specular.texture|planets/earth/earth_clouds.texture and technique earth - unitlevel > 2
0(16) : warning C7555: 'varying' is deprecated, use 'in/out' instead
0(17) : warning C7555: 'varying' is deprecated, use 'in/out' instead
0(82) : warning C7533: global variable gl_LightSource is deprecated after version 120
0(104) : warning C7533: global variable gl_TexCoord is deprecated after version 120
0(159) : warning C7533: global variable gl_SecondaryColor is deprecated after version 120
0(162) : warning C7533: global variable gl_Color is deprecated after version 120
0(168) : warning C7533: global variable gl_FragColor is deprecated after version 120

Fragment info
-------------
0(16) : warning C7555: 'varying' is deprecated, use 'in/out' instead
0(17) : warning C7555: 'varying' is deprecated, use 'in/out' instead
0(82) : warning C7533: global variable gl_LightSource is deprecated after version 120
0(104) : warning C7533: global variable gl_TexCoord is deprecated after version 120
0(159) : warning C7533: global variable gl_SecondaryColor is deprecated after version 120
0(162) : warning C7533: global variable gl_Color is deprecated after version 120
0(168) : warning C7533: global variable gl_FragColor is deprecated after version 120

0(14) : warning C7555: 'varying' is deprecated, use 'in/out' instead
0(15) : warning C7555: 'varying' is deprecated, use 'in/out' instead
0(16) : warning C7555: 'varying' is deprecated, use 'in/out' instead
0(41) : warning C7533: global function texture2DLod is deprecated after version 120
0(76) : warning C7533: global variable gl_LightSource is deprecated after version 120
0(99) : warning C7533: global function textureCubeLod is deprecated after version 120
0(105) : warning C7533: global variable gl_TexCoord is deprecated after version 120
0(205) : warning C7533: global variable gl_Color is deprecated after version 120
0(224) : warning C7533: global variable gl_FragColor is deprecated after version 120

Fragment info
-------------
0(14) : warning C7555: 'varying' is deprecated, use 'in/out' instead
0(15) : warning C7555: 'varying' is deprecated, use 'in/out' instead
0(16) : warning C7555: 'varying' is deprecated, use 'in/out' instead
0(41) : warning C7533: global function texture2DLod is deprecated after version 120
0(76) : warning C7533: global variable gl_LightSource is deprecated after version 120
0(99) : warning C7533: global function textureCubeLod is deprecated after version 120
0(105) : warning C7533: global variable gl_TexCoord is deprecated after version 120
0(205) : warning C7533: global variable gl_Color is deprecated after version 120
0(224) : warning C7533: global variable gl_FragColor is deprecated after version 120

Creating planet Phillies with texture planets/rock.texture and technique  - unitlevel > 2
Creating planet JumpToEnyo with texture jump.texture and technique  - unitlevel > 2
Creating planet JumpToCardell with texture jump.texture and technique  - unitlevel > 2
Creating planet JumpToOldziey with texture jump.texture and technique  - unitlevel > 2
Creating planet JumpToEverett with texture jump.texture and technique  - unitlevel > 2
Creating planet JumpToStirling with texture jump.texture and technique  - unitlevel > 2
Creating planet Cephid_17 B with texture stars/red_star.texture and technique  - unitlevel > 2
Creating planet Wiley with texture planets/molten.texture and technique  - unitlevel > 2
Creating planet Broadway with texture sol/ganymede.texture|planets/rock.texture and technique  - unitlevel > 2
Min (0.000000, 0.000000, 0.000000) Max(0.000000, 0.000000, 0.000000) MinLumin 1.000000, MaxLumin 1.000000Read In Star Count 0 used: 2000
Min (0.000000, 0.000000, 0.000000) Max(0.000000, 0.000000, 0.000000) MinLumin 1.000000, MaxLumin 1.000000Read In Star Count 0 used: 38
Loading a starsystem
Loading Star System Crucible/Cephid_17
 Next To: Crucible/17-ar
 Next To: Crucible/Stirling
 Next To: Crucible/Cardell
 Next To: Crucible/Enyo
 Next To: Crucible/Everett
 Next To: Crucible/Oldziey
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast



and my

stdout
Code: Select all
 In path C:\VS\bin
Windows version 5 1
Vega Strike 
See http://www.gnu.org/copyleft/gpl.html for license details.

Using .vegastrike as the home directory
['C:\\VS\\bin\\python26.zip', '.\\DLLs', '.\\lib', '.\\lib\\plat-win', '.\\lib\\lib-tk', 'C:\\VS\\bin']
['C:\\VS\\data\\modules\\builtin', 'C:\\VS\\data\\modules\\quests', 'C:\\VS\\data\\modules\\missions', 'C:\\VS\\data\\modules\\ai', 'C:\\VS\\data\\modules', 'C:\\VS\\data\\bases']
0 joysticks were found.

The names of the joysticks are:
using NV_CUBE_MAP
Initializing optimizer
Compilation of technique fixed successful
Compilation of technique default successful
Compilation of technique default_simple successful
pox 119990000000.000000 -9000000.000000 -109990000000.000000
INFO: Missing video stream preintro.ogv
INFO: Missing video stream intro.ogv
Force feedback support disabled when compiled
Loading active missions True
Running python script...   IS NOW AT  Special/Empty

Launching bases for Special/Empty
Adding news
conditioning
nonzeroing
New selection: 0
Compilation of technique earth successful
Compilation of technique fireglass successful
using NV_CUBE_MAP
Loading active missions True
Special/Empty  IS NOW AT  Crucible/Cephid_17
Special
Showing splash screen!
Launching bases for Crucible/Cephid_17
Adding news
conditioning
nonzeroing
finding nonloaded quest
quest_tutorial
finding quest
quest_tutorial
nonpfact
Processing News
<campaign_lib.CampaignClickNode instance at 0x15B5A530>
[]
*** still no contingency
Compiling python module bases/launch_music.py
SERIOUS WARNING in AI script: no fast method to perform FacePerpendicular when type 5 is at least -340282346638528860000000000000000000000.000000 and at most 5000.000000 with priority 5.000000 for 30.000000 time
SERIOUS WARNING in AI script: no fast method to perform afterburn evade when type 15 is at least -340282346638528860000000000000000000000.000000 and at most 0.300000 with priority 6.000000 for 6.000000 time
SERIOUS WARNING in AI script: no fast method to perform afterburn evade when type 10 is at least -340282346638528860000000000000000000000.000000 and at most 0.500000 with priority 6.000000 for 7.000000 time
SERIOUS WARNING in AI script: no fast method to perform afterburn evade when type 7 is at least -340282346638528860000000000000000000000.000000 and at most 0.300000 with priority 6.000000 for 7.000000 time
SERIOUS WARNING in AI script: no fast method to perform FacePerpendicularFast when type 26 is at least 0.500000 and at



AMD Athlon X2 64 2.1 GHZ
Windows 7 Ultimate 64-bit
3GB RAM(2.75 Usable)
320GB HDD
nVidia 8200M G with 266.58 notebook drivers

It just crashes out of no where, have tried it a few times, all when im gaining speed in SPEC. I'm thinking it has something to do with an Afterburner i have installed? Or maybe its a problem with the script saying that since my ship is on one side of Serenity, then it had to try and evade it to get to Atlantis and the script is broken? I am unsure if there is a fix, going to try it again now and will post any comments as to what happens. This time i am going to start off in the direction to Atlantis rather than try to use the autopilot to navigate me, while in SPEC, around Serenity.
~VS Forever~
User avatar
SCghst1
Merchant
Merchant
 
Posts: 60
Topics: 18
Joined: Tue Aug 21, 2007 3:36 pm

Share On:

Share on Facebook Facebook Share on Twitter Twitter Share on Digg Digg

Re: My current Bug/Problem..

Postby SCghst1 » Tue Mar 15, 2011 12:08 am

Same thing happened again, this time it was further out into space after i had successfully cleared Serenity and was on my way to Atlantis. The only difference i see in the error logs (for the most part) is that this time stdout said something along the lines of
SERIOUS WARNING in AI script: no fast method to perform FacePerpendicularFast when type 26 is at least 0.500000 and at most 340282346638528860000000000000000000000.000000 with priority 6.000000 for 10.000000 time
SERIOUS WARNING in AI script: no fast method to perform FacePerpendicular when type 5 is at least -340282346638528860000000000000000000000.000000 and at most 600.000000 with priority 5.000000 for 10.000000 time
ship destroyed-no flightgroup
ship destroyed-no flightgroup
ship destroyed-no flightgroup
ship destroyed-no flightgroup
ship destroyed-no flightgroup
ship destroyed-no f


As you can see it looks like the error occured around the same time it was trying to destroy ships with no flight group? there was some fighting going on in the system but I am unsure of what this implicates.

stderr looking about the same
Code: Select all
cannot execute suborders as Linear Velocity Matchercannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast
cannot find AI script FacePerpendicularFast


By the way i forgot to mention, i am using the SVN current build of 0.5.1.13139
~VS Forever~
User avatar
SCghst1
Merchant
Merchant
 
Posts: 60
Topics: 18
Joined: Tue Aug 21, 2007 3:36 pm

Re: My current Bug/Problem..

Postby SCghst1 » Tue Mar 15, 2011 1:27 am

Seems like i might have fixed this issue. I replaced the current "Evade.xml" script with a previous one from the 0.5 "stable" and renamed the afterburnerevade.xml to something different so VS wouldn't use it. I would not say to recommend doing this until a dev. has approved of it considering it might make it more unstable but i was able to make my way to Atlantis for the first time since i flew to Serenity (therefore i played for about 5-10 mins. the first time then this happened, causing the game to be unplayable because it kept happening about 30 seconds into flight.). It seems to be running fine and smoothy, actually, the game is giving me the same, if not more, errors as before but it seemed to work fine. I will post more once i have done some more extensive testing to be sure that the revision by Phoenix to these two scripts that are causing the problems.
~VS Forever~
User avatar
SCghst1
Merchant
Merchant
 
Posts: 60
Topics: 18
Joined: Tue Aug 21, 2007 3:36 pm

Re: My current Bug/Problem..

Postby klauss » Tue Mar 15, 2011 9:09 am

That's weird, because I've been using the same changes in AI and it works fine.

Any chance to get a stacktrace from when it crashes?

Ie: if you download a free debugging tool like OllyDbg, and run VS in it, you could post the details of where and when it crashes.
Oíd mortales, el grito sagrado...
Call me "Menes, lord of Cats"
Wing Commander Universe
User avatar
klauss
Elite
Elite
 
Posts: 7243
Topics: 55
Joined: Mon Apr 18, 2005 7:40 am
Location: LS87, Buenos Aires, República Argentina

Re: My current Bug/Problem..

Postby SCghst1 » Tue Mar 15, 2011 8:12 pm

I simply cant get it to crash again after i had changed those scripts. I am guessing thats what it is, but as soon as it happens again with those scripts changed, i will post the debug info concerning it. Thanks Klauss
~VS Forever~
User avatar
SCghst1
Merchant
Merchant
 
Posts: 60
Topics: 18
Joined: Tue Aug 21, 2007 3:36 pm

Re: My current Bug/Problem..

Postby SCghst1 » Tue Mar 15, 2011 8:27 pm

Im not really sure what i should be looking for, as it has crashed again and i used OllyDB on it. Says something along the lines of "Single step event at ntdll.770900BF". And actually i am getting a whole mess load of errors. Impossible to debug to find out where the problem is.
~VS Forever~
User avatar
SCghst1
Merchant
Merchant
 
Posts: 60
Topics: 18
Joined: Tue Aug 21, 2007 3:36 pm

Re: My current Bug/Problem..

Postby SCghst1 » Tue Mar 15, 2011 9:54 pm

Edit: deleted..
Last edited by SCghst1 on Wed Mar 16, 2011 2:56 am, edited 1 time in total.
~VS Forever~
User avatar
SCghst1
Merchant
Merchant
 
Posts: 60
Topics: 18
Joined: Tue Aug 21, 2007 3:36 pm

Re: My current Bug/Problem..

Postby klauss » Tue Mar 15, 2011 10:02 pm

SCghst1 wrote:Im not really sure what i should be looking for, as it has crashed again and i used OllyDB on it. Says something along the lines of "Single step event at ntdll.770900BF". And actually i am getting a whole mess load of errors. Impossible to debug to find out where the problem is.


You don't debug yourself, you get a stacktrace (the exact point where it crashed) and post it here - hopefully, we can find some sense in it.

Usually, the lowest levels (inside ntdll and stuff like that) is useless, we look further up the stack to VS functions that called the OS and made it crash.

FacePerpendicularWhatever isn't on a script, but it's defined within the game engine's code - the stacktrace would tell us more or less where the bug is in the code.
Oíd mortales, el grito sagrado...
Call me "Menes, lord of Cats"
Wing Commander Universe
User avatar
klauss
Elite
Elite
 
Posts: 7243
Topics: 55
Joined: Mon Apr 18, 2005 7:40 am
Location: LS87, Buenos Aires, República Argentina

Re: My current Bug/Problem..

Postby SCghst1 » Wed Mar 16, 2011 2:07 am

Alright. I was running the game under WinDBG debugging tools. and here is the call stack first...

Code: Select all
WARNING: Stack unwind information not available. Following frames may be wrong.
wrap_oal!alcCloseDevice+0x708b
wrap_oal!alcCloseDevice+0x4ded
 


and here is what the command window showed

Code: Select all
Microsoft (R) Windows Debugger Version 6.12.0002.633 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.

CommandLine: C:\VS\bin\vegastrike.exe
Symbol search path is: *** Invalid ***
****************************************************************************
* Symbol loading may be unreliable without a symbol search path.           *
* Use .symfix to have the debugger choose a symbol path.                   *
* After setting your symbol path, use .reload to refresh symbol locations. *
****************************************************************************
Executable search path is:
ModLoad: 00000000`00400000 00000000`0143b000   Vegastrike.exe
ModLoad: 00000000`77330000 00000000`774dc000   ntdll.dll
ModLoad: 00000000`77510000 00000000`77690000   ntdll32.dll
ModLoad: 00000000`74ba0000 00000000`74bdf000   C:\Windows\SYSTEM32\wow64.dll
ModLoad: 00000000`74b40000 00000000`74b9c000   C:\Windows\SYSTEM32\wow64win.dll
ModLoad: 00000000`74b30000 00000000`74b38000   C:\Windows\SYSTEM32\wow64cpu.dll
(49c.b6c): Break instruction exception - code 80000003 (first chance)
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for ntdll.dll -
ntdll!CsrSetPriorityClass+0x40:
00000000`773e0fb0 cc              int     3
0:000> g
ModLoad: 00000000`76da0000 00000000`76ebf000   WOW64_IMAGE_SECTION
ModLoad: 00000000`75c20000 00000000`75d20000   WOW64_IMAGE_SECTION
ModLoad: 00000000`76da0000 00000000`76ebf000   NOT_AN_IMAGE
ModLoad: 00000000`76ec0000 00000000`76fba000   NOT_AN_IMAGE
ModLoad: 00000000`75c20000 00000000`75d20000   C:\Windows\syswow64\kernel32.dll
ModLoad: 00000000`75f80000 00000000`75fc6000   C:\Windows\syswow64\KERNELBASE.dll
ModLoad: 00000000`10000000 00000000`10019000   C:\VS\bin\OpenAL32.dll
ModLoad: 00000000`732d0000 00000000`73302000   C:\Windows\SysWOW64\WINMM.dll
ModLoad: 00000000`75dc0000 00000000`75e6c000   C:\Windows\syswow64\msvcrt.dll
ModLoad: 00000000`74c70000 00000000`74d70000   C:\Windows\syswow64\USER32.dll
ModLoad: 00000000`758f0000 00000000`75980000   C:\Windows\syswow64\GDI32.dll
ModLoad: 00000000`774e0000 00000000`774ea000   C:\Windows\syswow64\LPK.dll
ModLoad: 00000000`75d20000 00000000`75dbd000   C:\Windows\syswow64\USP10.dll
ModLoad: 00000000`753c0000 00000000`75460000   C:\Windows\syswow64\ADVAPI32.dll
ModLoad: 00000000`75c00000 00000000`75c19000   C:\Windows\SysWOW64\sechost.dll
ModLoad: 00000000`756a0000 00000000`75790000   C:\Windows\syswow64\RPCRT4.dll
ModLoad: 00000000`74c10000 00000000`74c70000   C:\Windows\syswow64\SspiCli.dll
ModLoad: 00000000`74c00000 00000000`74c0c000   C:\Windows\syswow64\CRYPTBASE.dll
ModLoad: 00000000`00240000 00000000`0026c000   C:\VS\bin\glut32.dll
ModLoad: 00000000`714c0000 00000000`71588000   C:\Windows\SysWOW64\OPENGL32.dll
ModLoad: 00000000`71490000 00000000`714b2000   C:\Windows\SysWOW64\GLU32.dll
ModLoad: 00000000`736a0000 00000000`73787000   C:\Windows\SysWOW64\DDRAW.dll
ModLoad: 00000000`73690000 00000000`73696000   C:\Windows\SysWOW64\DCIMAN32.dll
ModLoad: 00000000`74f20000 00000000`750bd000   C:\Windows\syswow64\SETUPAPI.dll
ModLoad: 00000000`75980000 00000000`759a7000   C:\Windows\syswow64\CFGMGR32.dll
ModLoad: 00000000`75b60000 00000000`75bef000   C:\Windows\syswow64\OLEAUT32.dll
ModLoad: 00000000`74d70000 00000000`74ecc000   C:\Windows\syswow64\ole32.dll
ModLoad: 00000000`750c0000 00000000`750d2000   C:\Windows\syswow64\DEVOBJ.dll
ModLoad: 00000000`713a0000 00000000`713b3000   C:\Windows\SysWOW64\dwmapi.dll
ModLoad: 00000000`00350000 00000000`003bd000   C:\VS\bin\xmlparse.dll
ModLoad: 00000000`1e000000 00000000`1e213000   C:\VS\bin\python26.dll
ModLoad: 00000000`76000000 00000000`76c49000   C:\Windows\syswow64\SHELL32.dll
ModLoad: 00000000`759b0000 00000000`75a07000   C:\Windows\syswow64\SHLWAPI.dll
ModLoad: 00000000`713e0000 00000000`71483000   C:\Windows\WinSxS\x86_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.30729.4974_none_50940634bcb759cb\MSVCR90.dll
ModLoad: 00000000`73470000 00000000`73477000   C:\Windows\SysWOW64\WSOCK32.dll
ModLoad: 00000000`75790000 00000000`757c5000   C:\Windows\syswow64\WS2_32.dll
ModLoad: 00000000`75b40000 00000000`75b46000   C:\Windows\syswow64\NSI.dll
ModLoad: 00000000`01440000 00000000`014a4000   C:\VS\bin\SDL.dll
ModLoad: 00000000`711a0000 00000000`7122e000   C:\Windows\WinSxS\x86_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.30729.4974_none_50940634bcb759cb\MSVCP90.dll
(49c.b6c): WOW64 breakpoint - code 4000001f (first chance)
First chance exceptions are reported before any exception handling.
This exception may be expected and handled.
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for ntdll32.dll -
ntdll32!LdrVerifyImageMatchesChecksum+0x6ce:
775b0f2b cc              int     3
0:000:x86> g
ModLoad: 71150000 7119b000   C:\Windows\SysWOW64\apphelp.dll
ModLoad: 71020000 710ac000   C:\Windows\AppPatch\AcLayers.dll
ModLoad: 73440000 73457000   C:\Windows\SysWOW64\USERENV.dll
ModLoad: 73430000 7343b000   C:\Windows\SysWOW64\profapi.dll
ModLoad: 6fd00000 6fd51000   C:\Windows\SysWOW64\WINSPOOL.DRV
ModLoad: 71610000 71622000   C:\Windows\SysWOW64\MPR.dll
ModLoad: 6eb10000 6ed28000   C:\Windows\AppPatch\AcGenral.DLL
ModLoad: 716a0000 71720000   C:\Windows\SysWOW64\UxTheme.dll
ModLoad: 74720000 7472f000   C:\Windows\SysWOW64\samcli.dll
ModLoad: 73570000 73584000   C:\Windows\SysWOW64\MSACM32.dll
ModLoad: 73350000 73359000   C:\Windows\SysWOW64\VERSION.dll
ModLoad: 713d0000 713d3000   C:\Windows\SysWOW64\sfc.dll
ModLoad: 713c0000 713cd000   C:\Windows\SysWOW64\sfc_os.DLL
ModLoad: 75e70000 75f7f000   C:\Windows\syswow64\urlmon.dll
ModLoad: 751f0000 753a6000   C:\Windows\syswow64\iertutil.dll
ModLoad: 75460000 7557a000   C:\Windows\syswow64\WININET.dll
ModLoad: 75bf0000 75bf3000   C:\Windows\syswow64\Normaliz.dll
ModLoad: 6f600000 6f859000   C:\Windows\AppPatch\AcXtrnal.DLL
FTH: (1180): *** Fault tolerant heap shim applied to current process. This is usually due to previous crashes. ***
ModLoad: 01ac0000 02afb000   Vegastrike.exe
ModLoad: 00000000`712e0000 00000000`712e6000   C:\Windows\SysWOW64\SHUNIMPL.DLL
ModLoad: 00000000`71140000 00000000`7114d000   C:\Windows\SysWOW64\SortServer2003Compat.dll
ModLoad: 00000000`75ae0000 00000000`75b40000   C:\Windows\SysWOW64\IMM32.DLL
ModLoad: 00000000`75a10000 00000000`75adc000   C:\Windows\syswow64\MSCTF.dll
ModLoad: 00000000`71110000 00000000`71135000   C:\Windows\SysWOW64\DINPUT.DLL
ModLoad: 00000000`71100000 00000000`71109000   C:\Windows\SysWOW64\HID.DLL
ModLoad: 00000000`75fd0000 00000000`75ffd000   C:\Windows\syswow64\WINTRUST.dll
ModLoad: 00000000`757d0000 00000000`758ec000   C:\Windows\syswow64\CRYPT32.dll
ModLoad: 00000000`753b0000 00000000`753bc000   C:\Windows\syswow64\MSASN1.dll
ModLoad: 00000000`70b70000 00000000`70ba9000   C:\Windows\SysWOW64\MMDevAPI.DLL
ModLoad: 00000000`70a60000 00000000`70b55000   C:\Windows\SysWOW64\PROPSYS.dll
ModLoad: 00000000`70ff0000 00000000`71020000   C:\Windows\SysWOW64\wdmaud.drv
ModLoad: 00000000`710f0000 00000000`710f4000   C:\Windows\SysWOW64\ksuser.dll
ModLoad: 00000000`70b60000 00000000`70b67000   C:\Windows\SysWOW64\AVRT.dll
ModLoad: 00000000`6fcf0000 00000000`6fcf8000   C:\Windows\SysWOW64\msacm32.drv
ModLoad: 00000000`6fce0000 00000000`6fce7000   C:\Windows\SysWOW64\midimap.dll
ModLoad: 00000000`057c0000 00000000`0598e000   C:\VS\bin\wrap_oal.dll
ModLoad: 00000000`738c0000 00000000`73932000   C:\Windows\SysWOW64\dsound.dll
ModLoad: 00000000`72240000 00000000`72265000   C:\Windows\SysWOW64\POWRPROF.dll
ModLoad: 00000000`75160000 00000000`751e3000   C:\Windows\syswow64\CLBCatQ.DLL
ModLoad: 00000000`057c0000 00000000`0598e000   C:\VS\bin\wrap_oal.dll
ModLoad: 00000000`6fca0000 00000000`6fcd6000   C:\Windows\SysWOW64\AUDIOSES.DLL
ModLoad: 00000000`6fc90000 00000000`6fc94000   C:\Windows\SysWOW64\KBDUS.DLL
ModLoad: 00000000`6f5f0000 00000000`6f5f4000   C:\Windows\SysWOW64\KBDUS.DLL
ModLoad: 00000000`07d50000 00000000`07eac000   C:\Windows\SysWOW64\ole32.dll
ModLoad: 00000000`69500000 00000000`6a37a000   C:\Windows\SysWOW64\nvoglv32.DLL
(49c.b6c): C++ EH exception - code e06d7363 (first chance)
(49c.b6c): C++ EH exception - code e06d7363 (first chance)
(49c.4c4): Integer divide-by-zero - code c0000094 (first chance)
First chance exceptions are reported before any exception handling.
This exception may be expected and handled.
*** WARNING: Unable to verify checksum for C:\VS\bin\wrap_oal.dll
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for C:\VS\bin\wrap_oal.dll -
wrap_oal!alcCloseDevice+0x708b:
057eaf8b f7f1            div     eax,ecx


hope this helps. looks like something with OpenAL
~VS Forever~
User avatar
SCghst1
Merchant
Merchant
 
Posts: 60
Topics: 18
Joined: Tue Aug 21, 2007 3:36 pm

Re: My current Bug/Problem..

Postby SCghst1 » Wed Mar 16, 2011 2:55 am

Image

Uploaded with ImageShack.us


Just noticed this... What is up with using an older wrap_oal.dll in the current SVn as opposed to years ago on 0.5.0? i am going to try and replace the older one with the newer and try to see if it makes any difference. also, i installed the newest openAL (i dont know if the one supplied with the binary installer was the newest) and the openAL SDK to see if it would make any difference. Will continue to test and post back reports. I'm trying to fix this on my own and if i find anything significant or a fix for this certain bug i will be sure to let all the Dev's know.
~VS Forever~
User avatar
SCghst1
Merchant
Merchant
 
Posts: 60
Topics: 18
Joined: Tue Aug 21, 2007 3:36 pm

Re: My current Bug/Problem..

Postby klauss » Wed Mar 16, 2011 9:16 am

That stacktrace says it's crashing in alcCloseDevice, which would suggest the engine aborted somehow - probably an uncaught exception.
Oíd mortales, el grito sagrado...
Call me "Menes, lord of Cats"
Wing Commander Universe
User avatar
klauss
Elite
Elite
 
Posts: 7243
Topics: 55
Joined: Mon Apr 18, 2005 7:40 am
Location: LS87, Buenos Aires, República Argentina

Re: My current Bug/Problem..

Postby pheonixstorm » Wed Mar 16, 2011 2:02 pm

I dont know about the wrap al but the openal.exe that installs with VS was the latest when I added the new sdk into the svn. Running dependancy walker I never found anything that requires wrap_oal so if its out of date I didnt know.. never seen the file needed by the VS exe
Because of YOU Arbiter, MY kids? can't get enough gas. OR NIPPLE! How does that mkae you feeeel? ~ Halo
User avatar
pheonixstorm
Elite
Elite
 
Posts: 1567
Topics: 113
Joined: Mon Jan 25, 2010 7:03 pm

Re: My current Bug/Problem..

Postby klauss » Wed Mar 16, 2011 2:14 pm

It may be loaded dynamically at runtime (similar to dlopen in linux land).
Oíd mortales, el grito sagrado...
Call me "Menes, lord of Cats"
Wing Commander Universe
User avatar
klauss
Elite
Elite
 
Posts: 7243
Topics: 55
Joined: Mon Apr 18, 2005 7:40 am
Location: LS87, Buenos Aires, República Argentina

Re: My current Bug/Problem..

Postby SCghst1 » Wed Mar 16, 2011 2:41 pm

Yeah i'm not too sure but if it wasnt really needed too much then it wouldn't be in the callstack errors. after i changed it, i was able to fly around and do missions for approx 30 minutes. I haven't played since then but i will continue testing. seems like that was the problem. Before it would crash within the first 2-3 minutes of flight.
~VS Forever~
User avatar
SCghst1
Merchant
Merchant
 
Posts: 60
Topics: 18
Joined: Tue Aug 21, 2007 3:36 pm

Re: My current Bug/Problem..

Postby pheonixstorm » Wed Mar 16, 2011 4:26 pm

Even dynamic libs will show in a dependancy search as they are required by the software at some point. Any dynamic library that gets called should show up no matter if it ever actually gets used or not. Thats in win land anyway.

I will have to load the game up later and run it for a bit and see if it crashes for me or not. Maybe can track the problem down... klauss has anyone reported anything like this on linux?
Because of YOU Arbiter, MY kids? can't get enough gas. OR NIPPLE! How does that mkae you feeeel? ~ Halo
User avatar
pheonixstorm
Elite
Elite
 
Posts: 1567
Topics: 113
Joined: Mon Jan 25, 2010 7:03 pm

Re: My current Bug/Problem..

Postby klauss » Wed Mar 16, 2011 5:08 pm

No, actually, if you open a DLL or SO with APIs, (like dlopen or LoadLibrary), then the dependency won't show on the binary itself - in fact, the dll file could be defined only at runtime (ie, "enter dll to open").

It's common to do so when you have multiple implementations, and must pick the right one based on runtime conditions (like processor model, or hardware present).

pheonixstorm wrote:I will have to load the game up later and run it for a bit and see if it crashes for me or not. Maybe can track the problem down... klauss has anyone reported anything like this on linux?


On linux, I've seen reports about shader bugs (that, as usual, kill ATI drivers). I've also been reported bugs with Intel and shaders (what's new right?)

But no OpenAL issues that I remember.
Oíd mortales, el grito sagrado...
Call me "Menes, lord of Cats"
Wing Commander Universe
User avatar
klauss
Elite
Elite
 
Posts: 7243
Topics: 55
Joined: Mon Apr 18, 2005 7:40 am
Location: LS87, Buenos Aires, República Argentina

Re: My current Bug/Problem..

Postby SCghst1 » Wed Mar 16, 2011 11:28 pm

I am at an unfortunate end considering i have Windows 7 64Bit along with a dual core & an integrated video card so it might be a come and go error for me but i played it for approx an hour and a half earlier today. absolutely no problems what-so-ever since i have changed that wrapoal.dll to the newer version of it.
~VS Forever~
User avatar
SCghst1
Merchant
Merchant
 
Posts: 60
Topics: 18
Joined: Tue Aug 21, 2007 3:36 pm

Re: My current Bug/Problem..

Postby klauss » Thu Mar 17, 2011 10:56 am

So... pheonix... don't you think we should ship the newer one?
;)

@SCghst1: did you reinstate the AI xml files you changed? (because I somehow doubt they're the problem)

And... out of curiousity... how come you're running Win 7 and your avatar is OpenSUSE's logo? ;)
Oíd mortales, el grito sagrado...
Call me "Menes, lord of Cats"
Wing Commander Universe
User avatar
klauss
Elite
Elite
 
Posts: 7243
Topics: 55
Joined: Mon Apr 18, 2005 7:40 am
Location: LS87, Buenos Aires, República Argentina

Re: My current Bug/Problem..

Postby SCghst1 » Thu Mar 17, 2011 7:56 pm

Haha, well i use OpenSUSE to do my coding. I have not reinstated those AI scripts yet, i will do so the next time i fire it up. I hope this clears things up for some people or atleast will give you guys some insight into any problems in the future.

Like you said Klauss it might not use it but if its in the libraries and the game inadvertantly calls on it even though its not going to use it, it might just not like that particular version.
~VS Forever~
User avatar
SCghst1
Merchant
Merchant
 
Posts: 60
Topics: 18
Joined: Tue Aug 21, 2007 3:36 pm



Return to Bug Triage

Who is online

Users browsing this forum: No registered users and 1 guest

cron