Page 1 of 1

Libboost-python version

PostPosted: Thu May 25, 2017 1:53 am
by ncrouch141
I'm trying to install Vega Strike on Linux Mint using the Ubuntu repo and I keep getting an error saying it needs an older version of Libboost-python. The current version is 1.58.0 and it wants 1.49.0 or earlier. I'm afraid enabling back ports is going to make my system unstable.

HP-650-Notebook-PC ~ $ sudo apt-get install vegastrike
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
vegastrike : Depends: libboost-python1.49.0 but it is not installable or
libboost-python1.46.1 but it is not installable or
libboost-python1.42.0 but it is not installable or
libboost-python1.40.0 but it is not installable or
libboost-python-1.38.1 but it is not installable or
libboost-python-1.34.1 but it is not installable or
libboost-python-1.33.1 but it is not installable
E: Unable to correct problems, you have held broken packages.

Re: Libboost-python version

PostPosted: Thu May 25, 2017 9:49 am
by loki1950
You might want to check out https://github.com/Taose/Vegastrike-taose which is am work in-progress to update to current libraries and compiler conventions.

Enjoy the Choice :)