wrap_oal.dll problem

Just downloaded Vega Strike and need help? Have a question but don't know where to start? Ask here.

wrap_oal.dll problem

Postby ScottHorn » Sun Jan 08, 2012 5:35 pm

I downloaded a copy of Vega Strike (0.50), played for a while, and then uninstalled it and switched to the subversion using tortoise svn. I played using it for a while until I encountered the commerce center disappearing problem I've read about. I'm not sure if they were destroyed or if they just ceased to exist. Long story short, I deleted the bin and data directories in my SVN folder and re-downloaded the latest SVN. Now every time I try to run Vega Strike, I get an error indicating that the program has "requested to terminate in an unusual way", and the error report that win xp tries to send to microsoft mentions wrap_oal.dll. I tried deleting/renaming the file as mentioned in other threads, but the same type of error occurs except this time it mentions msvcr90.dll. Before I attempted this reinstall the latest svn was running fine. I've tried using registry cleaners like CCleaner. I installed the 0.50 version on the website, and it seemed to work fine. Any ideas why I'm seeing this problem?
ScottHorn
Trader
Trader
 
Posts: 20
Topics: 4
Joined: Sun Jan 08, 2012 5:15 pm

Share On:

Share on Facebook Facebook Share on Twitter Twitter Share on Digg Digg

Re: wrap_oal.dll problem

Postby klauss » Sun Jan 08, 2012 8:25 pm

There's a known issue with the openal dll in the SVN tree. There's a fix somewhere in the forums, I think it was in the 0.5.1 beta1 release thread, maybe some other one. Try to search for it (or someone that knows already post here).
Oíd mortales, el grito sagrado...
Call me "Menes, lord of Cats"
Wing Commander Universe
User avatar
klauss
Elite
Elite
 
Posts: 7243
Topics: 55
Joined: Mon Apr 18, 2005 7:40 am
Location: LS87, Buenos Aires, República Argentina

Re: wrap_oal.dll problem

Postby ScottHorn » Mon Jan 09, 2012 5:29 pm

I found a few references to the wrap_oal.dll file and sound issues, but only one post that matched my problem (the msvcr90.dll file problem showing up after deleting wrap_oal.dll). So far no solution to this problem though. I'll play with it some more this evening and see what I can achieve. Suggestions are very welcome though, as I've already tried almost everything I can think of.
ScottHorn
Trader
Trader
 
Posts: 20
Topics: 4
Joined: Sun Jan 08, 2012 5:15 pm

Re: wrap_oal.dll problem - now MSVCR90.DLL problem

Postby ScottHorn » Sun Jan 22, 2012 2:34 pm

I still haven't found a solution to this problem. I've been running the 0.51 beta 1 version fine, but the latest SVN still gives me an error involving MSVCR90.DLL during startup. Is there a newer version of this DLL that I could insert into the VS directory in order to get it running? If not, is there a certain revision where this problem popped up, such that I could get the revision right before that. If I were to do so, would it still be possibly to upgrade the data directory only so that I could get some of the latest changes while keeping the same binaries?
I will admit that, though I've read the SVN instructions on the wiki, there may be something that I missed. I'm using tortoise-svn under win xp. When I choose to install the SVN, I'm given the option of the HEAD revision, or to choose my own. If I show the log and choose my own, the highest revision I can choose is 13279. It will not allow me to extend the date range beyond the date that 13279 was added. Is this normal behavior?
edit- are there any conflicts that could arise from having 0.51 beta 1 installed at the same time as having the SVN installed?
ScottHorn
Trader
Trader
 
Posts: 20
Topics: 4
Joined: Sun Jan 08, 2012 5:15 pm

Re: wrap_oal.dll problem

Postby klauss » Sun Jan 22, 2012 11:46 pm

The latest SVN bugs out on an assertion failure due to it being a tad out-of-date regarding the dataset. You'd have to revert data/techniques a bit (to r13066) to work this around.
Oíd mortales, el grito sagrado...
Call me "Menes, lord of Cats"
Wing Commander Universe
User avatar
klauss
Elite
Elite
 
Posts: 7243
Topics: 55
Joined: Mon Apr 18, 2005 7:40 am
Location: LS87, Buenos Aires, República Argentina



Return to User Help

Who is online

Users browsing this forum: No registered users and 1 guest

cron