installing on Ubuntu 20.04

Just downloaded Vega Strike and need help? Have a question but don't know where to start? Ask here.
Post Reply
jlchamberlian
Atmospheric Pilot
Atmospheric Pilot
Posts: 1
Joined: Sat Apr 24, 2021 7:50 pm

installing on Ubuntu 20.04

Post by jlchamberlian »

Sorry if this has been asked before, but I'm trying to install on Ubuntu 20.04, but am having trouble figuring out how. It seems like the information I am finding is out dated. If I could find updated instructions to do so either by command line or adding to the software installer, I would be grateful.

Thanks in advance
loki1950
The Shepherd
Posts: 5832
Joined: Fri May 13, 2005 8:37 pm
Location: Ottawa
Contact:

Re: installing on Ubuntu 20.04

Post by loki1950 »

Welcome aboard we are just getting ready to release 0.7 and we do have .deb files built check https://github.com/vegastrike/Vega-Stri ... tag/v0.7.0 for the engine and https://github.com/vegastrike/Assets-Pr ... tag/v0.7.0 for the game assets all you need to do is double-click and put in your password when asked.Use the py3 one for focal as Python 2 support is EOL.

Enjoy the Choice :)
my box::HP Envy i5-6400 @2Q70GHzx4 8 Gb ram/1 Tb(Win10 64)/3 Tb Mint 19.2/GTX745 4Gb acer S243HL K222HQL
Q8200/Asus P5QDLX/8 Gb ram/WD 2Tb 2-500 G HD/GF GT640 2Gb Mint 17.3 64 bit Win 10 32 bit acer and Lenovo ideapad 320-15ARB Win 10/Mint 19.2
User avatar
alexis92
Trader
Trader
Posts: 16
Joined: Thu Mar 24, 2022 11:11 pm

Re: installing on Ubuntu 20.04

Post by alexis92 »

Just wanted to make use of this thread to ask, is installing this on an Ubuntu 20.04 Virtual Machine recommended? Has it been tested before? Or do you recommend native installs?
loki1950
The Shepherd
Posts: 5832
Joined: Fri May 13, 2005 8:37 pm
Location: Ottawa
Contact:

Re: installing on Ubuntu 20.04

Post by loki1950 »

Try to avoid installing in a Virtual Machine as vegastrike has a tendency of overwhelming the graphics drivers and VM's use what is essentially software rendering so your frame rate is very low and border line unplayable,It can be done but not a nice experience.

Enjoy the Choice :)
my box::HP Envy i5-6400 @2Q70GHzx4 8 Gb ram/1 Tb(Win10 64)/3 Tb Mint 19.2/GTX745 4Gb acer S243HL K222HQL
Q8200/Asus P5QDLX/8 Gb ram/WD 2Tb 2-500 G HD/GF GT640 2Gb Mint 17.3 64 bit Win 10 32 bit acer and Lenovo ideapad 320-15ARB Win 10/Mint 19.2
User avatar
alexis92
Trader
Trader
Posts: 16
Joined: Thu Mar 24, 2022 11:11 pm

Re: installing on Ubuntu 20.04

Post by alexis92 »

Understandable, native installs it is then. Thank you!
loki1950
The Shepherd
Posts: 5832
Joined: Fri May 13, 2005 8:37 pm
Location: Ottawa
Contact:

Re: installing on Ubuntu 20.04

Post by loki1950 »

BTW there are .deb's and .rpm's available on the GitHub release page https://github.com/vegastrike/Vega-Stri ... tag/v0.8.0 there are two versions of the 64-bit build for focal GLVND and LEGACY differing ways of handling Open GL.

Enjoy the Choice :)
my box::HP Envy i5-6400 @2Q70GHzx4 8 Gb ram/1 Tb(Win10 64)/3 Tb Mint 19.2/GTX745 4Gb acer S243HL K222HQL
Q8200/Asus P5QDLX/8 Gb ram/WD 2Tb 2-500 G HD/GF GT640 2Gb Mint 17.3 64 bit Win 10 32 bit acer and Lenovo ideapad 320-15ARB Win 10/Mint 19.2
obulle
Explorer
Explorer
Posts: 9
Joined: Mon Dec 14, 2020 9:04 am

Re: installing on Ubuntu 20.04

Post by obulle »

Hi Loki, hi there!
made a while I didn't check how goes this nice vs project... just noticed it is now going 0.8 :shock: nice!!
And as I'm using currently ubuntu 20.04, well, told to myself "just have a try"...

so I followed the tuto given here https://www.vega-strike.org/blog/2022/0 ... 0-release/ but finally got the following:

Code: Select all

 vega-strike : Dépend: libboost-atomic1.74.0 mais il n'est pas installable
               Dépend: libboost-chrono1.74.0 mais il n'est pas installable
               Dépend: libboost-date-time1.74.0 mais il n'est pas installable
               Dépend: libboost-filesystem1.74.0 mais il n'est pas installable
               Dépend: libboost-log1.74.0 mais il n'est pas installable
               Dépend: libboost-python1.74.0 mais il n'est pas installable
               Dépend: libboost-regex1.74.0 mais il n'est pas installable
               Dépend: libboost-system1.74.0 mais il n'est pas installable
               Dépend: libboost-thread1.74.0 mais il n'est pas installable
               Dépend: libffi8ubuntu1 mais il n'est pas installable
               Dépend: libgdk-pixbuf-2.0-0 mais il n'est pas installable
               Dépend: libicu67 mais il n'est pas installable
               Dépend: libnsl2 mais il n'est pas installable
It seems many packages are not officially available for ubuntu 20. So my only concern is: as it is proposed in this topic it's possible to install on 20.04, is it safe to install those packages that rather seems to be designed for 21.04+ ?? I'm just worried about the idea I could break something in my system that could lead to serious/critical problems latter... It is in general not advised to use a version package not design for other system versions.
Thanks!
loki1950
The Shepherd
Posts: 5832
Joined: Fri May 13, 2005 8:37 pm
Location: Ottawa
Contact:

Re: installing on Ubuntu 20.04

Post by loki1950 »

Not sure asked one of the code mavins to come comment.

Enjoy the Choice :)
my box::HP Envy i5-6400 @2Q70GHzx4 8 Gb ram/1 Tb(Win10 64)/3 Tb Mint 19.2/GTX745 4Gb acer S243HL K222HQL
Q8200/Asus P5QDLX/8 Gb ram/WD 2Tb 2-500 G HD/GF GT640 2Gb Mint 17.3 64 bit Win 10 32 bit acer and Lenovo ideapad 320-15ARB Win 10/Mint 19.2
the_mtn_who_glides
Merchant
Merchant
Posts: 50
Joined: Thu Aug 29, 2019 2:07 pm

Re: installing on Ubuntu 20.04

Post by the_mtn_who_glides »

Hmm. That's surprising.

Which package did you install? Vega-Strike_v0.8.0-py3-GLVND-Ubuntu-focal_x86_64.deb? Or Vega-Strike_v0.8.0-py3-LEGACY-Ubuntu-focal_x86_64.deb? (The "focal" is the most important part.)
obulle
Explorer
Explorer
Posts: 9
Joined: Mon Dec 14, 2020 9:04 am

Re: installing on Ubuntu 20.04

Post by obulle »

Hi all,
the_mtn_who_glides, you're right... I stupidly followed the link from the install link on home page, without taking care of that (it leads to hirsute version deb file by default for me). So it couldn't work. Just tried now with the focal version from the github page, and it installed without any problem...

:D

Just now have to try it and I'll report if success or not.

Thx for the help !
User avatar
alexis92
Trader
Trader
Posts: 16
Joined: Thu Mar 24, 2022 11:11 pm

Re: installing on Ubuntu 20.04

Post by alexis92 »

loki1950 wrote: Thu Apr 28, 2022 1:57 am BTW there are .deb's and .rpm's available on the GitHub release page https://github.com/vegastrike/Vega-Stri ... tag/v0.8.0 there are two versions of the 64-bit build for focal GLVND and LEGACY differing ways of handling Open GL.

Enjoy the Choice :)
This link doesn't seem to be working for me, just wondering if it's something on me end?
Post Reply