Page 1 of 1

big good surprise... and first big problems...

Posted: Mon Dec 14, 2020 9:52 am
by obulle
Hello guyz!

I had a big and very good surprise this morning when I had the strange idea to download and try to install VS again on my computer... not only it is not dead, but more... there was a new version dating a few weeks earlier!!! :D
I played VS for a long time before, something like... 15 years ago??!! Even try to participate a time to translations of the game (I'm french)... but as it didn't show any evolution with time I finally gave up :(
I didn't need a long time to decide: I downloaded the latest release from github for my ubuntu 16.04 (vega-strike_v0.6.0-Ubuntu-xenial_x86_64.deb file) and launched it for install with the classical sudo apt-get...
First very stranger problem I got: apt-get didn't see it!!

Code: Select all

zoz@zoz:/home/zoz/Téléchargements$:/home/zoz/Téléchargements$ ls vega-strike_v0.6.0-Ubuntu-xenial_x86_64.deb 
vega-strike_v0.6.0-Ubuntu-xenial_x86_64.deb

zoz@zoz:/home/zoz/Téléchargements$ sudo apt-get install vega-strike_v0.6.0-Ubuntu-xenial_x86_64.deb
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet vega-strike_v0.6.0-Ubuntu-xenial_x86_64.deb
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « vega-strike_v0.6.0-Ubuntu-xenial_x86_64.deb »
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « vega-strike_v0.6.0-Ubuntu-xenial_x86_64.deb »

Ok, so i tried with just apt... the same... with dpkg -i??? OK!! It says it unpacked and configured it:

Code: Select all

$ sudo dpkg -i vega-strike_v0.6.0-Ubuntu-xenial_x86_64.deb
Sélection du paquet vega-strike précédemment désélectionné.
(Lecture de la base de données... 397373 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de vega-strike_v0.6.0-Ubuntu-xenial_x86_64.deb ...
Dépaquetage de vega-strike (0.6.0) ...
Paramétrage de vega-strike (0.6.0) ...
I told myself "let's try!!"... nothing :cry:

Code: Select all

$ vegastrike
Registering codec ogg.
 In path /usr/bin
Vega Strike  
See http://www.gnu.org/copyleft/gpl.html for license details.

GOT SUBDIR ARG = 
Found MODDIR = /mods
USING HOMEDIR : /home/olivier/.vegastrike As the home directory 
CONFIGFILE - No config found in home : /home/olivier/.vegastrike/vegastrike.config
CONFIGFILE - No config found in data dir : /vegastrike.config
CONFIG FILE NOT FOUND !!!
Panic exit - no configuration
I couldn't find the old vssetup or and vssetting that was present in the old versions. However my system says it is installed:

Code: Select all

$ vssetup 
Error: Failed to find Version.txt anywhere.

"well... no problem, just try to install it from source and it will be fine!"...
So I downloaded the Assets-Production-0.6.2.tar.gz file from github repo, unpacked it and I saw there is a vsinstall.sh (but no README file or any help to start with all the process). I supposed I just had to launch this script in the command line...
But no way to get it. Once the script is finished, can just do no more than what I got with the deb file And I couldn't get more with the vsUTCS_v0.6.2.deb...

:(

I'm surely missing something but from here I'm totally lost.
Can anyone here tell me how to get around this install process please? If it's impossible I'll go back to 0.5 version (I didn't expect to find a newer one so it's not a problem) but i'd find it very cool to test this new version.

Thanks a lot and don't get lost in the coldest sea ;)

Re: big good surprise... and first big problems...

Posted: Mon Dec 14, 2020 7:29 pm
by loki1950
First off welcome to the forum obulle vssetup name has been changed to vegasettings as well as been update to use gtk3 instead of gtk2 I have asked two of our main coders to chime in on your issue so hang in for a short while. We should have been more explicit on the GitHub download pages you need two .deb file one is just the engine/utilities the other is the assets which are needed since we are not in most repo's yet apt get install is not the way to go not surprised it could not find it in the Ubuntu repos.

Enjoy the Choice :)

Re: big good surprise... and first big problems...

Posted: Mon Dec 14, 2020 8:03 pm
by temporalbeing
Certainly welcome back, and we'll help you get going again.

One of the things we've changed is that we've split the engine and assets into separate releases. We're doing this to help encourage the use of the engine for multiple story lines and game assets (f.e https://github.com/pwcu/privateer_wcu). We're still working out how to get a proper repo up so folks can use a repo and get both more easily.

It looks like you've installed the Vega Strike Engine but have not yet installed the VS Upon the Coldest Sea assets. Please go to https://github.com/vegastrike/Assets-Pr ... tag/v0.6.2 for the new assets package. After that you'll just have to tell it where to find the assets, or use a script like https://github.com/vegastrike/Assets-Pr ... /v0.6.2/vs or the https://github.com/vegastrike/Assets-Pr ... ke.desktop shortcut (Linux DEs).

For Version 0.6.0, the settings is still the old name `vssetup`; it'll be changing with the upcoming 0.7.x to help avoid issues with UAC and other things that want to request admin priv based on names.

EDIT: We added a page talking about installation to the website - https://www.vega-strike.org/install/

Re: big good surprise... and first big problems...

Posted: Wed Dec 16, 2020 9:14 am
by obulle
:D
I got it fine!!

thank you a lot for those tips that definitely gave me the exit to paradise! It works as for the old good 0.5 version I remember, with musics and the (wtf) complicated gameplay and keyboard use I don't remember all the keys but I'll find readily the knots I had made with my fingers :lol:
Just one more question: I just found a version 0.6.0 for the engine but a 0.6.2 for the assets, am I right with it or there is better to do? It seems to work fine anyway but I just ran it for a few minutes, I'll try it more extensively this evening.

Whatever it's a great pleasure to see that this project is kind of born again and seems very dynamic!! Nice job and pleaeeeese, don't give up :D

Re: big good surprise... and first big problems...

Posted: Wed Dec 16, 2020 12:43 pm
by Captain_Kal
Great job resuming the development of this wonderfull game. We can't have enough open world space combat/trading games.

A small problem:
Since I am not a Linux user, I created a VMware Virtual machine with an Ubuntu 18.04 distro, and installed version 6 of Vegastrike in it. I could not get past the menu, since mouse movement was erratic.

I know it has something to do with VMware 16, since in a real intel atom based tablet with a LXLE installation(Ubuntu 18.04 based distro) it works (although with minimal settings and a 800x600 resolution. And it was still dreadfully slow!!!)

If you can spare the time, could you take a look at it?

Re: big good surprise... and first big problems...

Posted: Wed Dec 16, 2020 5:06 pm
by loki1950
Not surprised that it's slow we have an awful lot of code to go through for each frame and virtual machines of any kind always add software overhead even using M$ WLS 2 it's slow on really hi end hardware we are working on getting a Windows build we need a dedicated person that is familiar with Visual Studio and C++ as most of our current devs are Linux users.
@obulle no problem with that version mismatch the only difference between 0.6.0 and 0.6.2 of the assets is the bump in version in one text file :shock: we have not bumped the engine version yet as there was no need to do so BTW for the keymap in game hit the "esc" key and see all the key bindings :wink:

Enjoy the Choice :)

Re: big good surprise... and first big problems...

Posted: Wed Dec 16, 2020 6:31 pm
by obulle
Hello Loki (and all the others too :) ),
ok thank you for this clarification. there is another thing I can't do at the moment, it is getting the vsettings working. When I try to launch it I get the following:

Code: Select all

$ vsettings 
/usr/bin/vsettings: ligne 12: vegasettings : commande introuvable
It seems the script vsettings looks for another command, called vegasettings. But I couldn't find it on my system. Do I need to install another package?? Or is it the old vsetup?
The reason I need it is quite simple... the current game display is kind of stamp like and if I could change my screen resolution, well... it could be playable :lol:
Any idea??

Thanks a looooooOOOOt :D

PS: and another reason I need it. I don't remember exactly, but I thought one could use mouse to steer or move the ship, am I wrong? For the moment the game doesn't recognize my mouse, I just can play using kb. Not a problem in itself but it's not as fun...

Re: big good surprise... and first big problems...

Posted: Wed Dec 16, 2020 7:23 pm
by loki1950
Sorry the name change for vssetup is for version 0.7.0 not 0.6.0 and yes you can use the mouse for steering two different modes I like the Glide mode as for resolution one of our devs is running on 4X he has even updated our backgrounds the vssetup app will change the resolution for you as well as a few other things.

Enjoy the Choice :)

Re: big good surprise... and first big problems...

Posted: Wed Dec 16, 2020 8:49 pm
by obulle
Haaaa ok, does it mean I need to install the 0.7.0 if I want to configure VS?
Meanwhile I fell back many years before by finding the vegastrike.config file!! I could then enable mouse without using vssetup, as in old time :lol:
However I have problems with some keys combinations: shift+1 is in fact shift + & on my keyboard, which is azerty/french keyboard... configuring this in the vegastrike.config makes vegastrike crash at start. the problem is when I do shift+& (that should be 1) then shift+_ (which should be 8 to zoom) in game to see around or closer etc, it freezes the screen and then it starts zooming and never ends... Obliged to esc then quit.
I think there is a problem with camera management, but I didn't remember I had this in 0.5 version.

Re: big good surprise... and first big problems...

Posted: Wed Dec 16, 2020 11:37 pm
by loki1950
You should have vssetup from the 0.60 deb. Yeah the app expects a US keyboard not sure on how to compensate for the azerty layout will check with our devs on our gitter chat where you are welcome we even have French dev so he may have something to say aboard key assignments.

Edit:Turns out we had an issue filed for that https://github.com/vegastrike/Vega-Stri ... issues/212

Enjoy the Choice :)

Re: big good surprise... and first big problems...

Posted: Thu Dec 17, 2020 5:42 pm
by temporalbeing
@obulle Would it be possible to verify with 0.5? If not, okay. I filed https://github.com/vegastrike/Vega-Stri ... issues/370 to track the camera aspect.

Full disclosure: This probably won't get fixed until 0.9.x. We're working to get 0.7.x out the door; and will be quickly following with moving to Python3 in 0.8.x as Python2 is entirely EOL after 2020/12/31. I have no timeline right now for 0.9.x right now.

Re: big good surprise... and first big problems...

Posted: Thu Dec 17, 2020 5:47 pm
by obulle
Hello!

I tried to run vssetup. I got the following:

Code: Select all

~$ vssetup 
Error: Failed to find Version.txt anywhere.
There is a /usr/share/vegastrike/Version.txt but vssetup seems not to find it. I copied it in my personal .vegastrike in my home but that didn't work either...
Any way to modify it other than with manually? I'm not sure about what I do in the vegastrike.config file...

@temporalbeing: ok i'll try soon and I'll report you :)
thx!

Re: big good surprise... and first big problems...

Posted: Thu Dec 17, 2020 6:45 pm
by obulle
OK, not so simple to install 0.5 in fact... I remember that at the time I tried, a looonnnng time ago, I didn't have any problem... It seems it's different now. I've downloaded the tar.gz from the github for 0.5.1 version and try to compile it. I had to relocate my libpython2.7.so coz configure didnt' find it but all passed ok. but when coming to make... I get something I don't know how to get around the problem: it asks for boost patch for gcc44, need to get some hpp it seems... I installed the full list of libboost package I can find and the hpp make asks for are on my system. make tells:

Code: Select all

patch -N -p0 < boost_gcc44.patch || true
can't find file to patch at input line 5
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: boost/1_35/boost/mpl/aux_/numeric_op.hpp
|===================================================================
|--- boost/1_35/boost/mpl/aux_/numeric_op.hpp	(revision 54830)
|+++ boost/1_35/boost/mpl/aux_/numeric_op.hpp	(working copy)
--------------------------
File to patch:


I have to supply a path to the boost patch... don't really understand what I have to do from here. If I ignore, make asks for other patches... it seems endless.
not sure I will be able to re install an old version easily... I'm looking in my discs and CDs if I have an old archive I could have saved. I 'll tell you if I succeed...

Re: big good surprise... and first big problems...

Posted: Thu Dec 17, 2020 9:46 pm
by loki1950
Please that would not be very productive as the API of all most all of the dependent libraries has changed why we had to update the whole source code tree which took us about six months to do as a group you on your own may not be as lucky :wink: Running 0.5.1 just can not be done with current distros though the Windows version can be installed under Wine as it can be configured to emulate Windows XP and 7 that maybe a more productive approach.

Enjoy the Choice :)

Re: big good surprise... and first big problems...

Posted: Fri Dec 18, 2020 8:59 am
by obulle
yes I understand I won't fight more in those conditions. I have an old linux version already installed on another computer that I always kept working. I hope i'll be more luck with the following versions :) And I also have a win 7 one that works. I just wanted to see if something new on the 0.6. But I understood that it's not the case, so no problem.